Neatline static image layer won't show


I’m trying to use Neatline with a static image layer on a site, but the Neatline editor only shows a blank page. The error message given in the Chrome’s debugging page is this:
Uncaught TypeError: Cannot read property ‘toGeometry’ of null

I’ve tried the following:
Check the image’s URL in a browser, it’s fine.
Use the OpenStreetMap for the same Neatline exhibit instead of static image layer, it works fine.
Use the same image in another site’s Neatline exhibit which is hosted the same VM and with same setting, it works fine.

I’m using Omeka 2.4.1, and Neatline 2.5.1.

I’d appreciate your help! Thank you in advance.


1 Like

Hi Theresa,

I usually find that static images are slightly out of the editing frame. Usually zooming out a few times will reveal one corner so that I can recenter the exhibit and get the correct zoom level set for my default.

If you can send the image to me, or point me to a URL for it, I’m happy to look at what might be happening.


Hi, Ronda,

Thanks a lot for your reply!

I don’t think it’s the zooming issue, I already tried that (to zoom out many times),it didn’t help, still blank. While on my another site which uses the same image this issue doesn’t happen at all.

And, I noticed that if I tick the Spatial Querying box in the Exhibit Settings page and go to Neatline editor, even the left panel will turn blank, leaving only the zoom in and out button on the right. If the Spatial Querying is not ticked the left panel appears, only the image part is blank. I don’t know if this means anything,

My image is here:, however since it’s on a VM with a fake URL I’m not sure if you can see it, so I just uploaded it below. I was going to upload a couple of screen shots, but found that as a new user I’m only allowed to attach one image (perhaps I can attach it in another reply?).

I really feel lost, many thanks for your help!

Image used:


H Theresa,

Thanks for the image and for the additional info. I need to chat with our developers about this. The left editing tools panel going blank is definitely odd.

Also, just to clarify,

  1. are you using Chrome on a Mac or PC? Not sure if that would make any difference whatsoever, but the more info I have the better.
  2. Is the image stored as an Omeka item? or is it simply in a web accessible folder?

Adding the image as an Omeka item, then using the URL for the background static image in Neatline, I’m not seeing any problems either with the static querying box checked or unchecked, but as I said, I need to chat with the developer crew here.


Hi, Ronda,

I’m using a PC (Windows 7), but the Omeka installation is on a VM in Linux environment. I tried both Firefox and Chrome and got same result.

The image is stored on the VM in a folder which is accessible to all my Omeka sites. I also tried earlier to add my map as an item and use that item’s URL as the image layer, but with no luck.

The screen shot below shows what I got when I try to start the Neatline editor.

Thank you so much!



Our head of R&D has some troubleshooting suggestions, and a question.

First, when you tick the spatial querying box and the entire Neatline editor window goes blank, does this have any effect on the other Neatline exhibit/Omeka instance on the VM server?

And now the troubleshooting:
-Have you compared the Omeka and Neatline settings between the two Omeka instances? Are there differences?
-Do both Omeka instances have the same plugins and widgets installed and activated?

We’ve seen some instances where an plugin can interfere with Neatline functionality, and there’s obviously something different about the non-working exhibit. If we can figure out what that difference is, we might be able to get it working.


Hi, Ronda,

Thanks a lot for you and your colleague’s effort!

The site 1 (with problem) is actually cloned from the site 2 (without problem), the settings (I mean the details I can see in under the top level menu item ‘Settings’ next to Plugins, Appearance, and Users) are the same, except site 1 has one extra user.

I checked the plugin lists on both sites, there was only one on site 2 but not on site 1 (Docs viewer) and I activated it. However it doesn’t seem to make any difference. Both sites have 3 Neatline widgets installed: SIMILE, Text, Waypoints.

I also checked the Spatial querying box on site 2, and tried to get it ticked and not-ticked. The Neatline exhibit using the same map works fine in both cases.

Here are a few new findings on site 1, not sure if it means anything:

If I tick the Spatial querying box, and leave the zoom levels to 20 (default), I got that blank page in Neatline editor, the error message given in Chrome’s debugging panel is this:
Uncaught TypeError: Cannot read property ‘clone’ of null

If I leave Spatial querying box ticked and reduce the soom levels to 3, I still have blank page but the error message changed to this:
Uncaught TypeError: Cannot read property ‘toGeometry’ of null

Now I un-tick the Spatial querying box, zoom levels is still 3, The left panel in the Neatline editor appears now, although the image panel is still blank. I tried to zoom out many times but it didn’t make any difference. There is no error message in Chrome’s debugging panel. A screen shot is attached below.

Thank you very much for your patient and support!

Hi Teresa,

I had the same issue and found two fields in the database not being set.

If I edit the database at the table omeka_neatline_exhibits, find my exhibit through the id column, edit it, and
set image_height and image_width (in your case both 1368) the backgroundimage appears

Note: This is being reset to empty every time I edit the Exhibit Settings through the admin webinterface,
and I have to go to the database to set image_height and image_width again.

Note for development:
Maybe getimagesize can be improved, or is it easy to add two fields to the admin webinterface,
to enable users setting these values manually (which would then override the check through php).

Neatline getimagesize

Omeka OpenSeadragon getimagesize
github /dpla/omeka-OpenSeadragon/blob/143a7d08d14ca4d23be77bfb22dd19c42d838590/helpers/OpenSeadragonFunctions.php#L28

Omeka Core getimagesize
github /omeka/Omeka/search?utf8=%E2%9C%93&q=getimagesize

Great catch! Thanks. I’ve opened an issue for this

Hi, theinfosniper,

Thanks a lot for your message, and sorry for my late reply, I was away.

I don’t have access to the Omeka database so can’t try your suggestion. However my colleague who looks after the server must have done something because my image appears now!

Thank you,


Hello @rondagrizzle, @theinfosniper and Others,

I’m having exactly the same problem that Theresa did back a year ago. I’ve searched for any updates on the issue, or other people having the same problem since then, and found nothing. The issue opened in response to the theinfosniper’s reply appears to be still open. Ronda, has the R&D team learned anything new? I’m working on figuring out how to make the changes in the database that theinfosniper suggests (that is taking more detective work!), but in the meantime, I’m just wondering if there are any updates or other strategies to try.

The item I’m trying to work with is here (though I’ve tried over and over with different items and different exhibits):
I’m using Reclaim to host my Omeka installation.

Many thanks for any suggestions or ideas!

Hi Teresa (and Everyone),

This bug is in the process of being fixed and is currently part of the 2.6 release, which we’re planning for later this year.

I’ll bring this to the attention of the dev team so we can discuss whether the fix can go out sooner than this planned release.


Hi all,

At Ronda’s suggestion, we’ve posted a 2.5.3 release to provide a workaround for the getImageSize failure and to address a couple related image layer issues. The .zip file is available at

Thanks for everyone’s help in documenting and investigating this!


1 Like