Edit Panel Missing


#1

Hello,

I am experiencing an issue similar a Theresa here: to Neatline static image layer won't show and James here: Neatline 2.6: Image Layer Not Displaying as Default

I am using a static image layer in Neatline with Omega 2.6. I ticked “Use Current View as Default” to center my image and am now unable to see exhibit editing tools.

In public view, my image appears (still not centered) but when I click on my SVG layers, no records/text appears as it should.

This issue also occurred after I made theme changes, but I have switched back to the original theme since (The Daily) with no improvement. I have the below plugins activated.

It seems that Theresa’s issue from August 2016 was addressed with a 2.6 release. James’ May 12 issue, however, refers to 2.6.1. His inquiry was recently closed. Thank you very much for any assistance.

Thank you,
Emily


#2

Hi! Just chiming in with an update from my end: I know that @jeremyboggs was able to get the static image working without much issue on the Workshop site and that he believed a plugin or theme issue was likely causing the error (the theme I was using at the time was The Daily, which it sounds like was a theme in the mix here too). The project I was working on ended up being OK with using Google map layers to annotate and curate their spatially-oriented work, but we also went that route because of the issues we were unable to resolve, and I’ve been a little hesitant to recommend the static image layer option when I’ve discussed the (many other!) benefits of Neatline as a tool in recent on and off-campus conversations.


#3

The problem sounds quite similar to this old Neatline bug report which pointed the finger at the PHP setting allow_url_fopen needing to be enabled on the server.


#4

James, thank you very much for updating about your project. I am glad to hear that some issues were resolved with some plugin/theme changes. I have already moved away from The Daily for other user-experience related reasons, but have not had any luck restoring my Neatline records or editing panel. It is a shame that the static image layer never ended up working out for you.


#5

@jflatnes thank you for directing me to this solution. I will contact an IT specialist with access to our server to request these settings adjustments.


#6

It seems there were some changes designed to avoid this problem… (based on the other thread you linked to, I think) so it’s probably not exactly the same as that earlier issue.

There’s another wrinkle that could be related… the image you’re using is an https url… at least from here it causes a Forbidden response, while the http version doesn’t. That could be related to why Neatline is having trouble reading the dimensions of the image.