Icons missing/changed

We just updated Omeka-S with the latest updates and the pencil, trash can, and other icons are missing and an “I” with 2 dots above it are in their place. I’m not sure what I need to tell or send to my server manager to fix this. Should we try reinstalling the updates? Here’s a screen shot Dropbox - Screenshot 2021-10-27 113123.png - Simplify your life

You can typically fix this by doing a hard refresh on your browser.

Hi Jim, thanks for responding so quickly. I tried a hard refresh and a couple of other browsers but still have the strange icon with the i and the dots.

Do you have a link to a live example? It’s difficult to troubleshoot without one.

Hi Jim, it is on the admin side. Should I add you as a user so you can see it? If so, send me your email address please.


Could you open your browser’s web development tools and see if there are any errors in the console?

In console, it lists this: Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform

What does it say under the “Console” tab there?

Nothing under Console at the top of the panel (with Elements, Console, Sources, Network). in the bottom panel (console, what’s new, issues), this is listed in issues: Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform

We looked at your site and confirm that the icons aren’t being loaded correctly. It’s puzzling. It may be that your server is not reporting the correct MIME types for the font files - similar to this issue. You’ll need to talk to your systems administrator about it. We’ll continue to look into this.

Thank you Jim. My systems administrator does the basics for our Omeka-just the installation and updates so I’ll share with him your notes. If we are unable to fix it, should we uninstall the recent updates?

Unless you have a backup of the previous version’s database, I wouldn’t attempt to uninstall the recent updates. We have not see this error before. No one but you has reported it. This is why we think it must be something specific to your server. Even so, we’ll continue to look into it.

Okay-thank you so much for all of your help.

Northern Arizona University

One possibility that could help us investigate: do you see similar problems with the publicly-accessible icons (things like the magnifying glass for the search box, for example)?

If those are similarly broken and the site is publicly visible then we could look without having to log in.

Hi John, I am now getting errors trying to see the public side of the sites. I tried all of them and get this message

I spoke with my systems administrator and we do have a full back up from before the update. My students just started their projects for the semester and we have a limited amount of time so would uninstalling the updates be the fastest option for now to restore full functionality? We could try the update again after the semester ends.

Please follow the directions to retrieve error messages and paste the error here.

I just sent the request for the error log to my systems administrator. Thanks.

Hi John and Jim, here is the error report

Omeka S encountered an error
The current theme is not active. Its current state is “invalid_omeka_version”.
Exception: The current theme is not active. Its current state is “invalid_omeka_version”. in /www/ac.nau.edu/omeka-s/application/src/Mvc/MvcListeners.php:329
Stack trace:
#0 /www/ac.nau.edu/omeka-s/vendor/laminas/laminas-eventmanager/src/EventManager.php(321): Omeka\Mvc\MvcListeners->preparePublicSite(Object(Laminas\Mvc\MvcEvent))
#1 /www/ac.nau.edu/omeka-s/vendor/laminas/laminas-eventmanager/src/EventManager.php(178): Laminas\EventManager\EventManager->triggerListeners(Object(Laminas\Mvc\MvcEvent), Object(Closure))
#2 /www/ac.nau.edu/omeka-s/vendor/laminas/laminas-mvc/src/Application.php(310): Laminas\EventManager\EventManager->triggerEventUntil(Object(Closure), Object(Laminas\Mvc\MvcEvent))
#3 /www/ac.nau.edu/omeka-s/index.php(21): Laminas\Mvc\Application->run()
#4 {main}

OK: this one is easy: the theme did not get updated when Omeka S was updated. Just updating the theme(s) to current versions should fix this.