ZoteroImport no results

Hi, trying to import items from a Zotero Group to a local test install (using MAMP).

Installed the Zotero Import plug-in and tried importing from different groups - both public and closed ones.
All remain without results:

  • The message “Importing the group library. This may take a while.” appears
  • The status changes to (and remains on) “Started”
  • A collection is created with 0 items.

No further activity happens.

I activated errors.log and processes.log but both remain empty.

Hints on how to solve / make this work would be much appreciated. Thanks in advance!

Can you share with us one of the public group libraries you were trying to pull from? That way we can check if it works for anyone else. Thanks.

Hello, thanks for your support. The groups I tried were:

Group Type Public, Closed Membership
Group Library Only members can view and edit

Group Type Public, Open Membership
Group Library Anyone can view, only members can edit

Kind regards, Erwin

I could not find a good url for the first group you point to. For the second, with error logging on, I got the following error:
ERR (3): exception 'Zend_Db_Statement_Mysqli_Exception' with message 'Mysqli statement execute error : Incorrect datetime value: '2016-05-30T13:02:23Z' for column 'zotero_updated' at row 1' in /websites/omekadev/home/www/mebrett/Omeka/application/libraries/Zend/Db/Statement/Mysqli.php:214

Hi Megan - much thanks for trying. Not sure how or why I couldn’t get the error logging to work either, but that’s a separate issue, and might be fully related to my incompetence. Does the error mean I should correct something in the group records or better yet - check with the Zotero team what could cause the datetime value incorrectness? Thanks for your advice.

Erwin - I was running an odd version of Omeka. Trying again, I was successfully able to import from the Digital Strategy group. Out of curiosity, what url did you use in the Zotero Atom Feed URL field? Did you use https://www.zotero.org/groups/digitalstrategy or the group library feed (https://api.zotero.org/groups/484976/items/top?start=0&limit=25&format=atom&v=1)?

Hi Megan, sorry for the delay in getting back to this issue.
I did a fresh install to rule out any possible installation mistakes I made the first time and retried importing via the group library feed you mentioned (https://api.zotero.org/groups/484976/items/top?start=0&limit=25&format=atom&v=1). Still no luck. I’ll try to activate the errors.log and processes.log again to see if I can figure something out. Much thanks for your help!

Thanks for the update - let us know what your errors say.