Zoom levels in Mapping module

I am developing an Omeka S site for mapping and viewing items in heritage precincts, city neighbourhoods and streets using WMS overlays of historical maps geo-referenced using Tim Waters’ Map Warper http://mapwarper.net which allows anyone to upload, warp and serve a map to Omeka for overlays. This is a powerful tool (kudos to @jimsafley !) and one of the reasons I migrated to Omeka S.

However in the Map Warper (and other GIS tools like QGIS where one can browse a WMS map feed), one can zoom down to the closest scale of the original map, whereas the zoom levels in the Mapping module page views seem constrained to a different scale such that one cannot fully zoom to the extents of the WMS layer. This limits full visibility of my maps at building and street levels (and especially their text and labels and symbology).

This is the link to the Map Warper export tab with the WMS and other export options, and this is the Preview of the warped map with all zoom levels available. When piped into an Omeka map via WMS I cannot zoom down past a point.

I am not current on how WMS layers are served within Leaflet but it seems that the config in Omeka is also not zooming down to the basemap layers (such as OSM Streets) at their true scale either. Is some extent or constraint being applied? It would be useful to have some of this configurable – some of these options were available in the Neatline plugin for Omeka Classic’s map editor.

I created a branch that lets you set a minimum and maximum zoom limit for Mapping blocks. It’s currently in testing.

Thanks @jimsafley am testing it out myself now. Should I continue this thread here or contribute on Github?

Any place is fine…

The adjustable zoom levels and live indicator of levels is working great on my test Omeka S instance. Word @jimsafley