WMS Overlay with Geoserver

I need help setting up a WMS overlay in the mapping block. I have succeed setting this up with Map Warper georeferenced maps, but have not been able to accomplish it with geoserver or ArcGIS Online services. For instance, our geoserver has this geotiff (http://maps.binghamton.edu:8080/geoserver/SHWG/wms?service=WMS&version=1.1.0&request=GetMap&layers=SHWG%3Abgmflood&bbox=-8456740.480058866%2C5170728.6066675065%2C-8441498.051024169%2C5182679.196109417&width=768&height=602&srs=EPSG%3A3857&styles=&format=application/openlayers). The layer is SHWG:bgmflood. Can anyone explain what we need to put in the base URL and layer fields? many thanks.

Your link isn’t available (it’s maybe a service only accessible from within your university’s network?), so it’s hard to say for sure (and if it is only available within your network you’re going to have trouble using it for any outside visitors).

That being said, I would say for that the layer should be SHWG:bgmflood and the base URL should be http://maps.binghamton.edu:8080/geoserver/SHWG/wms

Hello. I am planning also to add the an extra overlay/layer. I can not see any options in admin interface, so I assume you need to extend the Mapping module?

All the best
H

The WMS overlays are available when editing a site page. Just add a new “Map by…” block to the page and you’ll see the WMS overlays section.

Last week, we offered a Zoom practicum for beginners on the Mapping Module in Omeka S. The resource is here: https://arcg.is/uDryC

1 Like

Many thanks to both of you!

Thank you. I had incorrectly assumed that the geoserver (which we just set up), would offer layers that would be publicly available. Indeed, these layers are not accessible outside of our network. Argh… Nevertheless, if Omeka S is running within the same network as the geoserver (both are within our institution), shouldn’t the mapping module be able to access and display the geoserver layers?

I need help setting up a map overlay using a service hosted on my ArcGIS Server. Here is url: https://elcamaleon.binghamton.edu/server/services/Skopyk/AHA_AS_C3194_E43887_F3_B__tif/MapServer/WMSServer
This does not produce any results in the map overlay block. Any suggestions?

I think it’s simply a case of specifying the layer you want to use. In this case the layer seems to be named just 0 (the numeral zero).

Thanks for your help. Where does ‘0’ come from? The layer should be named ‘AHA_AS_C3194_E43887_F3_B__tif’. Would the ‘0’ go in the layer field? And then, what would go in the Base URL?

The 0 is just the name of the layer from your WMS server: you can use “GetCapabilities” to have it list the layers. The way your server seems to work s is that each image is its own “server” endpoint.

As for what you should put:

The URL you listed above that ends in “WMSServer” should be the Base URL, and then just put 0 into the Layer field.

Wow! That works! Thank you so much!