Verovio Installation on Omeka S 3.0.2

Hi,
I’m getting an error message when installing the Verovio Module by @Daniel_KM . The error message reads: “Error: Verovio MEI Viewer requires Omeka S ^1.2.0 || ^2.0.0”.
Do I need to install an older version o Omeka? The latest release for the module was very recent so I’d be surprised if that was the issue here.
I’m new to all this, so please be gentle!

Thanks

To install with Omeka S v3, you need to install last release (3.3.0.7).

Thanks, @Daniel_KM
I don’t know how I missed that on the GitLab page!