Using Resource Template Fields when deploying CSV Import?


I’m part way through an Omeka S build and I am testing uploads using CSV Import and File SideLoad. Getting the hang of it, BUT … I need a bit of help.

I’m fairly savvy about metadata, and have designed my metadata crosswalks using DCM as a backbone. This means that I have three different Resource Templates (Correspondence, Manuscripts, and Objects) with a range of Field Names for data that are all linked to DCM Terms. Thanks to DCM, even though these three different Resource Templates describe different kinds of collection objects, the ‘People Places, Things’ that join them all up are consistently referenced by the same DCM Terms. This of course enables visitors to harvest letters, manuscripts and objects related to individuals, specific dates, locations etc. That’s what’s great about Omeka S!

However, when I use CSV Import, and I ‘map’ my column headings (which are identical to the Resource Template Field Names) to the DCM Terms, I end up with an import that uses the exact DCM Terms and NOT the column heading names which are the ones also found in my Resource Templates. I feel certain that there is a simple trick I am missing, but I can’t find it in the CSV Import Manual or in the Forum…

Hoping that newbie questions can also help – by shedding light on missing bits in the documentation if nothing else.

Thanks in advance for help!

If I’m understanding your issue correctly, you may just need to go to your Admin settings and adjust your property label settings. You can do that for the Global Admin and individually within site settings.

Thank you! Grateful for the guidance!

I had a look at this setting and the options do not intuitively appear to give me an option to show Resource Template terms – only Show Vocabulary and Show Terms (meaning DC terms).

To give a concrete example from my metadata crosswalks, I am using DC Term ‘Provenance’ for both manuscripts and letters, but want the field name on the Omeka Site to say ‘Collection Management History’. This works fine if I am creating individual Items manually, but I can’t seem to get the platform to re-create this when I use CSV Import, even/especially when I am heading a column in the CSV Import file with that exact phrase…

Any further thoughts?

Are you setting the resource template for the items when you import them? Either with the Basic Settings if you’ve got a CSV with all items of the same template, or by a column with the Generic Data setting (accessed from the + sign on the individual column mappings)?

Hi Again, thanks so much for the speedy guidance!

I tried originally with Basic Settings, using the Resource template picker, and picking the names of the Template that exactly matches my column headings. That didn’t work, but there may have been other problems with the Import caused by my own learning curve :slight_smile:

I’ve just looked at the tab ‘Map to Omeka S data’, where to date I have been (under ‘Add mapping’) picking the Dublin Core Properties that I am using. Perhaps I should instead be using the ‘Generic data’ option, and selecting ‘Resource template (by label)’. In that case, should I ALSO be choosing ‘Resource template’ under ‘Basic Settings’?

Thanks in advance!

So, that generic data setting is only if you have a column in your CSV that indicates the resource template you would like to us. Some people create CSVs with items of many types and classes and then they indicate the template for each individual item. So, if you don’t have a CSV with multiple templates at play then you can ignore the generic data settings.

Creating CSVs by template and indicating that association in the Basic Settings is definitely the easiest way to go. That should allow you to pick up the alternate labels that you’ve set in the template.

Thanks so much for this. I will check everything with my use of Basic Settings, Resource Templates and CSV column headings and be sure that everything lines up exactly. It’s also great to know that it is possible to create and deploy CSV files with a column designating the Resource Template for each Item you want to generate – amazing!

Many thanks, and have a great weekend!