Uploaded Media Images not showing

I am using Omeka 4.0.1. I have it hosted on Reclaim Hosting. When adding an item I add the item and then go to the media tab. I am using the option to upload an image from my computer.

Items page: I see a list of my items and no images are showing on the thumbnails.
Individual Item: If I click on the individual item I can see the metadata for the item. On the right hand side of that page I see the ID, Visibility, Sites, created, owner, media options. At the top there is no image in the thumbnail. At the very bottom in “media” there is no image in thumbnail. However, if I click on the Title link next to that empty thumbnail, it takes me to the Media page for that specific item. I CAN see the item here and can zoom in and out on it. This is true for most of my uploaded items. Some of them are still not showing here either and all the fields look the same.

Also, I did upload the following modules/plugins via the Reclaim Hosting site.
Create Missing thumbnails: However, I have this- Error: Create Missing Thumbnails requires Omeka S ^3.0.0 (which makes no sense since I have a newer version)
Image Server
Universal Viewer
And a couple of IIIF modules (which I have no Idea what that is but it seemed like it had to do with images so I installed it).

How can I get the images to show in my thumbnails AND where I have included media on a page, it is not showing up there either. Suggestions? I am very, very new and all of this is a bit overwhelming, so please be very basic in your suggestions.

Can you share screenshots of the places you are and aren’t getting images displaying? I want to be sure we’re talking about the same things.

Thank you,

OK, thanks. It looks from what you’ve shown that thumbnails are just not being created at all for your installation, so there’s probably a problem with ImageMagick on your server, or the configuration related to that.

Can you also share the contents of the “System information” page? It’s linked at the bottom of every admin page.

Here you go. Additionally, there is this issue with this module, but I am not sure why I get that message since I’m running a later version. Just a reminder that I’m hosting this on Reclaim hosting…
Thank you for you help!

For simplicity’s sake at the moment, go ahead and disable all those IIIF plugins and Image Server. They aren’t needed for the basic thumbnail and image display features, and could confuse matters a little bit.

Can you click the “Get ImageMagick version” button at the bottom of the system information page and see what it reports?

As for the problem module: the issue here is that the caret there, the ^ in the error message means that the module only works with Omeka S 3.x.x versions: in other words, you have too new of a version of Omeka S to run that module. Anyway, if you aren’t getting thumbnails made in the first place, that module won’t fix anything for you.

Thank you for explaining things so succinctly and in laymans terms. I really appreciate it:). When I click the “Get ImageMagick Version”. I get the error message “Unable to execute command”.

OK: this is definitely the problem: your output should be like this there (this is mine):

Version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
Copyright: (C) 1999-2021 ImageMagick Studio LLC
License: https://imagemagick.org/script/license.php
Features: Cipher DPC Modules OpenMP(4.5) 
Delegates (built-in): bzlib djvu fftw fontconfig freetype heic jbig jng jp2 jpeg lcms lqr ltdl lzma openexr pangocairo png tiff webp wmf x xml zlib

As far as I know, the configuration this page is showing for the ImageMagick directory. Have you talked with Reclaim about this? They should be able to confirm that ImageMagick is installed and its location on the server. I don’t think I’ve seen this particular issue from Reclaim users before.

One thing you can do for yourself: turn on error logging and then try uploading an image. There should be some entries in the log indicating what happened when Omeka tried to make a thumbnail, which could help us figure out the problem here.

Okay. I reached out to Reclaim Hosting and this was their reply:
Screen Shot 2023-04-12 at 8.18.09 PM

I checked my site and nothing had changed so I asked them that. They said that: You likely need to specify the ImageMagick directory path which should be,


So, I checked back on my systems Information and this is what I am seeing:

I also checked to see what my thumbnails are doing, and something has changed. Previously, I could see my image here on this page. I no longer see it here, but I can see it when I click the red “original” link that is at the bottom of the page.

If you click the “Get ImageMagick Version” button again now, is the output there different than you were getting before?

If the output is more like mine was in my previous post (it can be a little different, but should be similar), then that means that ImageMagick is there and working, and what you’d want to do after that is to try uploading a new image to see if that new one has the thumbnails and looks correct.

Fixing the ImageMagick on your server won’t, by itself, fix the images and thumbnails for the images you’ve uploaded already.

Success!!! Thank you so much for your help. I really appreciate it.