Upload err, and linking item file from external server


I have recently become the administrator of an Omeka site that has been running for a number of years and have been asked to upload a pdf file to a collection. Initially I tried to upload the document directly as a pdf file but received an error when I clicked “add item”:

The item was created and the metadata was saved, but without the file that was attached. I realized that the document was over the maximum file size limit, so I tried splitting it into parts and received the same message.

After speaking with colleagues I have found out that in the past items have been uploaded to an external server and then linked to the Omeka page, which is a process I am not familiar with. I have since uploaded the document to the external server, but I am unsure about how to put it in Omeka. Can anyone explain this process? Is there some way of adding a file that is linked out to a different server?

Apologies if this is an obvious question, thank you for any help you might be able to provide!

This looks like an issue coming from the Neatline plugin, specifically with it trying to use the SQL function AsText (which is used for some spatial/geographic functionality).

There’s an incompatibilty with older Neatline and newer versions of MySQL (8 and up). Updating to the most recent version of Neatline should resolve the problem.