Upgrading Omeka-S to latest: Blank Screen

I am This Close to being done with my upgrade to Omeka-S in Production.

I’ve done everything in the docs to prepare my Omeka-S_NEW directory. I swap it in for my existing /omeka-s/ directory and go to hit /omeka-s/admin to perform the actual database migration.

Blank screen.

All this is working great in my Vagrant box.

Looking for issues:

All is chowned apache:apache
.htaccess file is present

Not sure why I’m getting a blank screen.

Advice appreciated!

Mark

More, I can get back up and running by just swapping back in my /omeka-sOLD/ dir for /omeka-s/ and I’m back in bidness, on OLD.

So not an issue with Apache config, PHP config, etc.

More: As I look through my Vagrant file, I see that the Google Analytics Module must be removed before the database migration can run,

I’ve just now done this. Still no joy.

I reactivated my Omeka-S OLD and deactivated Google Analytics from there. Then attempted the upgrade again.

Same result: Blank screen

Is the screen also blank at just /omeka-s/?

A blank screen typically indicates a fatal PHP error. You might explore turning on error display or checking your PHP and/or Apache error logs for fatal errors, to see what exactly is happening. Usually modules aren’t a major problem for this kind of thing with Omeka S, since new major versions require modules to specifically claim they are compatible before we’ll load them at all.

Thanks!

From error log:

[Fri Aug 19 13:38:33.748082 2022] [php7:error] [pid 4245] [client 52.7.141.1:33792] PHP Fatal error: Declaration of Laminas\ServiceManager\ServiceManager::get($name) must be compatible with Psr\Container\ContainerInterface::get(string $id) in /var/www/html/omeka-s/vendor/laminas/laminas-servicemanager/src/ServiceManager.php on line 40

My PHP version:

php --version
PHP 5.4.16 (cli) (built: Apr 1 2020 04:07:17)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

So ancient PHP version? I am surprised Omeka-S ever ran on it.

Putting in ticket to have PHP upgraded.

Hmm I’d have to go back and look but I’m pretty sure no released version of Omeka S ever ran on PHP 5.4. It’s possible that the version that runs on the web isn’t the same as the default php binary’s. In fact now that I look at it, the error message indicates the “php7” module is being used, so you probably do have some PHP 7 version running, at least.

Is this just a “zip” copy of Omeka S, or are you using Git? A mismatch between the “vendor” code installed by Composer and the Omeka S code could cause this kind of problem. From a zipped copy, that wouldn’t be a factor though.

Thanks, John,

I suspect there is something peculiar about this particular system. Looking into it.

Mark

https://omeka.org/s/docs/user-manual/install/

Looking at the system requirements, it’s looking like anything higher than PHP 7.2 works.

Our sysadmin is therefore upgrading PHP to the latest supported version: 8.2.

Mark