Universal Viewer won't load


#1

Hi,

the Universal Viewer doesn’t seem to load correctly after I upgraded to the latest version. I am using the latest IIIF Server module.

Here’s an example: https://eastbaypunkda.com/s/east-bay-punk-digital-archive/item/612#?c=&m=&s=&cv=

Any thoughts on what might be causing this?

Thank you for your help!


#2

The last version of Universal Viewer seems not to integrate well with some themes. So probably some css rules to fix.


#3

Thank you, Daniel! I was using the Center Row theme a tried to change it to the Default one (I also tried Cozy and The Daily) but I seem to be getting the same error.


#4

It works on my install, so it is not clear where the issue is.


#5

The Javascript console seems to suggest that we’re missing a file – even though the file it’s asking for seems to be in the right place!

19%20PM 01%20PM


#6

Hi Daniel, just wanted to report that thanks to a heads up of the folks in the New Media Lab at CUNY Grad Center I was able to solve the issue.

The js is requesting the file inside uv-en-gb-theme, but the directory is named uv-en-GB-theme. Those are the same on a Mac (usually) or PC but not on most servers, which are case sensitive. So when I renamed the folder to “uv-en-gb-theme” the plugin started working again.

I wonder if the calling in the script was meant to be that way?


#7

Fine!
The original files are lowercase only (uv 3), so I think there was a mix of an old version and a new one in your case. Maybe an update that doesn’t removed old files.