Universal Viewer setup error cannot display images

Hi there,

I was trying to setup Universal Viewer but unfortunately I have encountered the following error (below).

I tried a number of things such as:

  1. List item checked the file permissions in case the plugin has issues accessing the .jpg

  2. List item checked the .js file still exists that is reported in the error box ie https://cdnjs.cloudflare.com/ajax/libs/jquery/1.10.2/jquery.min.js

  3. List item check the logfile however I was unable to locate this even after reading the documentation - can someone please let me know if this is available for the plugin?

If there is any tips to point me to the right direction that would be greatly appreciated!

Thanks in advance,

There may be an incompatibility with another plugin and with another jquery release. Can you check with a standard theme, and without any plugin except Universal Viewer, then re-enable each one until the error appear?

Thanks for the suggestion Daniel!
Unfortunately I tried disabling all plugins and switched to the defaulty ‘Thanks Roy’ theme and it didn’t work.

It still presents with the same issue.

This bug seems not to be related to Omeka or to the plugin, but to the server, the network, the browser or the widget.

So try a page with the widget alone (see examples at https://github.com/UniversalViewer/universalviewer). If an issue appears, post an issue on it.

Thanks for the suggestion Daniel.

I was trying to locate the logfiles for the plugin, are there error logs for this by any chance?

There is no specific log for the plugin and internal errors use the main logs/errors.log.

Hi Daniel,

We seem to be getting closer to resolving the issue! The issue I think why we’re seeing blank screen on Omeka+UV is
because we’re serving Omeka using HTTPS, but UV is trying to service/display the media files from HTTP:

Inline images 1
In particular error is this:

Mixed Content: The page at ‘https://repository.monash.edu/collections/play/9#?c=0&m=0&s=0&cv=0’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://repository.monash.edu/media/164/info.json’. This request has been blocked; the content must be served over HTTPS.
send @ jquery.min.js:6
ajax @ jquery.min.js:6
(anonymous) @ bundle.min.js:9
ExternalResource.getData @ bundle.min.js:9
(anonymous) @ bundle.min.js:4
Utils.authorize @ bundle.min.js:4
(anonymous) @ bundle.min.js:4

From the plugin’s “routes.ini”, it looks like that’s where the place where the paths/routes are configured.
And there’s a notion of “{schemes}” in there, e.g:


Question, is how to customise the scheme to make it HTTPS instead of HTTP?

Fixed with https://github.com/Daniel-KM/UniversalViewer4Omeka/commit/87df63d74cc944bb587116d2c84fa6cec91b4eed

Check the version 2.4.1 on omeka.org too.