Universal Viewer adds special characters to items URL

For some time now, Universal Viewer adds a string of characters to items URL:

before http://trajes.delwende.org/elementos/Kimono-estampado-ninio_VES0452
now http://trajes.delwende.org/elementos/Kimono-estampado-ninio_VES0452#?c=0&m=0&s=0&cv=0&xywh=0%2C-111%2C910%2C1402

Any idea about the reason for this behavior?


I add some more information.
The behavior before is in item show when I add the helper ‘echo $this->universalViewer($item)’ into the aside section, without check the option ‘Append to “Item show”’ in the config of the plugin. If this option is checked, the url is ok but the viewer is shown two times (aside and append). By now, i leave checked the option but i hide the viewer appended to item
Some idea, please?

The “append to items show” allows to display the viewer for people who don’t have access to theme. In your case, you can disable it.

The viewer adds a query directly in the url to manage some params in the case you want a specific one. By default, it adds a default query, but this is a javascript addition, not via the server. So you can ask to the developper of the viewer to remove the default params and to keep them only when they are specific (UniversalViewer/universalviewer).

Daniel, thank you for your response.
I will follow your suggestion to ask the developer but, in the meantime, I will keep the option checked but with the appended viewer hidden.

This topic was automatically closed after 250 days. New replies are no longer allowed.