Unable to override the site-list-entry.phtml file

Hi everyone,

I’m trying to override the site-list-entry.phtml file. I have placed the file in my theme folder under the following sub directory view-> common. And it is being called from the index.phtml file, as default.

Am I missing something to override the following file? Do I need to add something in the local.config file as done for the index file to override?

Thank you,

Is this within a site, or the default “blue background” view?

Since there’s no theme for those default views, you can’t override in that way. You can within a site, though.

This is for the default view, that list’s all the sites. I have already overridden the index.phtml by directing it to my theme folder using the below configuration, in the local.config.php file:

    'view_manager' => [
        'template_map' => [
            'omeka/index/index' => __DIR__ . '/../themes/name/view/omeka/site/index/index',
        ],
    ],

How can I Override it in this case?

Thank you jflatnes for the above comment, it was actually an eye opener on how to go on this in a different way. What I ended up doing is changing the default site in the setting to another site I created. Then I created another theme just for the following index site overwriting the site-list-entry block and other files accordingly .