Unable to log in the administration board after installing Omeka 2


#1

Hello to all. Three months ago I installed Omeka 2.4.1 on a virtualbox running Ubuntu 5.2.1-22ubuntu2 (according to a search using “cat / proc/version” in the terminal) on a computer. And it worked well. (Except that the computer was not strong enough to fully support a virtualbox working without a ton of lag, but that’s not the matter here.)

This week I tried to install Omeka again, this time on a computer fully devoted to Ubuntu and not just a virtualbox. The running version on this one is Ubuntu 5.3.1-14ubuntu2.1. I tried to follow the exact same procedure I used successfully not so long ago, but this time it failed.

When I tried to install Apache, PHP, MySql, phpMyAdmin and Imagemagick using the following code in the terminal (as I did the first time):
sudo apt-get install apache2 php5 mysql-server php5-mysql phpmyadmin imagemagick
I received an error message which eventually send me searching for a more recent version of PHP and Apache, namely PHP7 and Apache 2.4. Then I configured Apache, including writing the lines

<Directory "var/www/html">
AllowOverride All
</Directory>

in the 000-defaut.conf file under the “DocumentRoot /var/www/html” line. I created my database in phpMyAdmin. I installed Omeka. Success! All seemed to work well. Except that when I try to log in the administration board, all I have is a 404 Not Found page saying:

The requested URL /omeka/admin/users/login was not found on this server.
Apache/2.4.23 (Ubuntu) Server at localhost Port 80

If I search for localhost/omeka I reach the front page of the site (which is, evidently, blank aside the title and the default features).

So I tried to look for answers on the Internet, found some old Omeka forums, but the pages were from years ago and apparently the solution back then was, either to write the famous “AllowOverride All” line that I did actually wrote, or to deal with a .htaccess file which, as it appears (correct me if I’m wrong), is no longer needed in the Omeka 2 versions.

I rechecked every step of the installation process and the only differences I found between the success of the first time and the current failure, is that I used slightly different versions of Ubuntu, Apache and PHP. Can it be the source of the error? If not, does somebody have any idea about where that comes from and how to fix it? Many thanks by advance.

PS: I’m not used to Linux, actually what I described here is just about the extent of my experience! (Nor am I, by the way, a native English-speaker, I hope it doesn’t show too much, but in any case, my apologies for the possible faults.)


#2

the .htaccess file is indeed still needed. If that’s missing, that’ll be the first place to start.


#3

Thanks for your reply!


closed #5