Unable to load manifest

migrating a site, new version is here: http://vrc2.princeton.edu/researchphotographs/

Message appears telling me unable to load manifest, yet, I can see a manifest: http://vrc2.princeton.edu/researchphotographs/iiif/19955/manifest

though it differs from the previous version (old server version)

The difference being that under thumbnail there is no service and context.

I tried going back to a slightly older version of the Iiif module and I get the same error. What to try next.

Note: I tested all the migration out on a mamp pro and there was no manifest issue there.

Nobody answered but a colleague had the same issue - I’m on a Mac with LAMP, she is on C-Panel but both of us were getting a strange Manifest could not load error. I solved the problem: Use the pencil to go into the Site to edit, choose the settings tab at the top (next to Info Tab). Then at the very bottom, under Players, instead of the deafualt of 4.0, I switched it to 3.1.1 (more modern) and now I no longer get the Manifest error.

Thanks! This worked for me as well.