Unable to get items to display in Neatline Time

We recently installed the Neatline Time plugin (version 2.1.0) for our Omeka Instance (version 2.4.1). We were able to configure the timeline but have been unable to get items to display. One known issue is that some of our items have a year in the date field which we will need to correct. I tried to unsuccessfully to get two items to display with the following date format - January 1, 2016

Here is the link to our timeline

Here is an example of one item with a date that Neatline should be able to convert according to the information on GitHub:

I am wondering if we need to modify all of our dates so they are in the YYYY-MM_DD format and/or I haven’t configured the plugin properly.

Let me know if you need more information.


Yes, all dates should be ISO 8601 formatted (https://en.wikipedia.org/wiki/ISO_8601).

The display itself of the date can be changed by a filter on the element Dublin Core Date.

Anyway, you can try the upgrade of the plugin (https://github.com/Daniel-KM/NeatlineTime), that will be integrated upstream soon.

Thanks for confirming. We will definitely try the upgrade.

My colleague encountered a problem when attempting install the updated Neatline Time plugin. The installation went smoothly but the timeline no longer shows. It appears as a white box, no date markings, nothing. The rest of the page looked the same as with the original Neatline Time plugin. There are several features on the updated plugin that we would like to use. Can you think of a reason why the timeline doesn’t show? Thanks.

It looks like a jQuery issue. Is it in the admin page or in the public view?

It is on both the admin page and the public view.

Did you check the config “Edit Metadata” and “Edit Item Query” ?

My colleague made the timeline public so you can see it.

The settings are the same as those that worked in Neatline Time v 2.1.0 (item title = title, item description = description, and item date = date available, the center date, and the item query parameters were used successfully in Neatline Time v 2.1.0)
Here are the configurations.
In the plug in configuration settings:
Timeline library = Simile
Add secondary link = Browse timelines
Main timeline = none selected
Item title = Title
Item description = Description
Item date = Date
Item end date = none
Render year = Mark entire year
Center date = none
Viewer = {} (left as is, which is the default)

Edit metadata configuration for the test timeline settings:
Title = Test timeline
Description = Testing v 2.2.5
Status = public
Featured = not featured
Item title = Title
Item description = Description
Item date = Date Available
Item end date = none
Render Year = Mark entire year
Center Date = 1957-06-01
Viewer = {} (left as is, which is the default)

Edit item query for the test timeline settings:
Title contains “Eisenhower” (which does have a date in the date available field) in the American University Historical Photographs collection. This should produce one result.

Yes, there is an issue. In fact, it works if you use the internal assets (in config.ini of Omeka), but not the online assets (by default). I pushed a fix on github.

Thanks. We will try this out next week.