Ubuntu Upgrade Issue with SQL

We upgraded today from Ubuntu 16.04 to Ubuntu 20.04.02. This includes apache2 as well as MySQL. Now we are getting an error at https://archives.uwp.edu.

This is what it says in the error.log for apache2:

Variable ‘sql_mode’ can’t be set to the value of ‘NO_AUTO_CREATE_USER’.\n\nConfirm that the information in your db.ini file is correct.

When I look at the sql_mode in phpmyadmin, I can’t see “NO_AUTO_CREATE_USER” in the variable list for sql_mode. I expect it is a part of MYSQL 8 having it automatically set.

Here are the variables for phpmyadmin in sql_mode: ONLY_FULL_GROUP_BY,STRICT_TRANS_TABLES,NO_ZERO_IN_DATE,NO_ZERO_DATE,ERROR_FOR_DIVISION_BY_ZERO,NO_ENGINE_SUBSTITUTION

I’ve changed to STRICT_TRANS_TABLES as it was set to something different. It’s not working. I’m trying to get into mysql on the server, but I’m unable to. I’ve looked at the db.ini file and there is nothing about NO_AUTO_CREATE_USER in there.

SQL settings from inside the database:

Can anyone help me with this issue? Thanks in advance!
Melissa Olson

The issue is definitely related to MySQL 8.

The problem is going to be that you’re using an older version of Omeka: versions 2.7 and up have a fix for this specific problem with MySQL 8. Upgrading to the latest version of Omeka Classic should resolve this issue.

We updated and it worked. Thanks so much!