Trying to install Omeka S on Cpanel hosting

Hello everyone,
After a long time experimenting with Omekas on virtual machines I’ve bought some hosting space with a CPanel UI, and I’m trying to install Omekas there. All the specifics are active, and I suppose it works much like Wordpress, so I created a dedicated db and user, I put all the files from the Omeka S folder into public_html, then added the user and db into the Database.ini file inside Omeka S. I’ve tried twice and still doesn’t work: I have a 404 error both when I try to go to the domain link and when I try to go to the usual domain/admin page. Could someone point out any error I could have made or any passage I skipped? Thank you in advance!

Ps: I don’t have any access to installatron or other services; Installatron is active but only has Omeka Classic.

Is your domain really pointing to your server? If yes, is your root for that domain really public_html? Other things that you could check are the .htaccess (are you also copying it do public_html and is it properly set up?) and directory permissions (in this case, I believe you’d get another error). If it is your server that is returning the error 404 (and not just your browser, after failing to connect to it), you could check the logs to see what exactly is happening.

Thank you for your answer, I’ll explain better:
I have a hosting service where apparently mod_env is not available due to security concerns, and the only thing similar is the setenvif_module.
I’ve triple checked everything you suggested and everything is on point, I’ve also previously tried Omeka S on a debian virtual machine without any issues of this kind whatsoever.
I found another question on the forum which is similar to mine, this one, and I’ve left the .htaccess file as it was then added the line on bootstrap.php. Still nothing, I get the same error in the error log:

Invalid command ‘SetEnv’, perhaps misspelled or defined by a module not included in the server configuration

Whenever I try to connect to domain/omeka-s/admin it gives off this error:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

I think it is strictly a module issue, but I can’t still find any solution around it. Is there any possible way to do so without directly using the SetEnv in .htaccess?

Solved right away by making the hosting service enable mod_env

1 Like


We’re on Reclaim Hosting – don’t know if this is the same cPanel environment as yours – but having a similar problem with 500 (a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request) and also 304 error (server configuration error) trying to upgrade from 3.1.0 to 3.1.1. I can’t tell if mod_env is enabled or not (we don’t have access to apache configuration parameters beyond the .htaccess file as far as I can tell).

The web server logs didn’t tell me anything much, Omeka S logs are empty, and I went back to Omeka S 3.1.0.

Anyone else been able to run 3.1.1 on ReclaimHosting or have any insights?



I’m surprised there’d be… really any difference at all between 3.1.1 and 3.1.0.

Those versions are very similar, with the only changes being a fix to one particular area and some translation updates. Neither of those changes should cause the kinds of errors you’re seeing.

I’m thinking there must be something else going on here. Have you asked Reclaim about it?

In my experience, installing from github at Reclaim does sometimes mess with the folder (755) and file (644) permissions. So, I’d check to see that is all okay. That usually resolves my initial 500 error upon install.

Yes, I’ve asked Reclaim about it. They did note that mod_env is enabled, as I’d expected. I installed the downloaded .zip file from Github. I’ll check permissions more closely — good idea. Right, given 3.1.1 being primarily a bug fix there shouldn’t be much to break between 3.0.1. I did a cursory permissions check but could easily have missed something.

Reclaim does says they’ll make 3.1.1 available as soon as Installation makes has it ready… Just checked the site and still only 3.0.1 there.


Update: thanks Sharon for the suggestion to double-check file permissions. I changed individual file permissions (*.json, *.php, *.lock) to 644 in the root omeka-s directory and that seems to have fixed the problem. The earlier settings were 664. I’ll convey to Reclaim, as well.

Thanks, again.



This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.