Trouble with multiple Modules

Below is an error log for my Omeka-S installation. I have been trying to install multiple modules after updating Omeka-S, and many of them dont seem to be loading correctly at all. I have found that Easy Admin now loads after a lot of fussing, A bunch of others like Custom Vocab wont load, which then wont let me load Annotate and a few others. Very frustrating.

I thought maybe the version of PHP was a problem, but I dont think it is…running 8.2 i think.

Any help appreciated.

[10-May-2024 17:50:09 UTC] PHP Warning: require_once(/home/tjfinano/ Failed to open stream: No such file or directory in /home/tjfinano/ on line 61
[10-May-2024 17:50:09 UTC] PHP Fatal error: Uncaught Error: Failed opening required ‘/home/tjfinano/’ (include_path=‘.:/opt/cpanel/ea-php82/root/usr/share/pear’) in /home/tjfinano/
Stack trace:
#0 /home/tjfinano/ Log\Module->init(Object(Laminas\ModuleManager\ModuleManager))
#1 /home/tjfinano/ Laminas\ModuleManager\Listener\InitTrigger->__invoke(Object(Laminas\ModuleManager\ModuleEvent))
#2 /home/tjfinano/ Laminas\EventManager\EventManager->triggerListeners(Object(Laminas\ModuleManager\ModuleEvent))
#3 /home/tjfinano/ Laminas\EventManager\EventManager->triggerEvent(Object(Laminas\ModuleManager\ModuleEvent))
#4 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->loadModule(Object(Log\Module))
#5 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->onLoadModules(Object(Laminas\ModuleManager\ModuleEvent))
#6 /home/tjfinano/ Laminas\EventManager\EventManager->triggerListeners(Object(Laminas\ModuleManager\ModuleEvent))
#7 /home/tjfinano/ Laminas\EventManager\EventManager->triggerEvent(Object(Laminas\ModuleManager\ModuleEvent))
#8 /home/tjfinano/ Laminas\ModuleManager\ModuleManager->loadModules()
#9 /home/tjfinano/ Omeka\Mvc\Application::init(Array)
#10 {main}
thrown in /home/tjfinano/ on line 61

This error is saying that you have the Log module but you haven’t installed its dependencies. If you checked it out with Git or downloaded the source, then you need to run Composer to install the dependencies.

Most users download zip copies of the modules that already have dependencies like that set up. The downloads linked here should all be set up that way.

Thanks. I will give that a go.

Ive tried to replace any and all modules with ones downloaded from the Omeka-S site and it is still throwing the same errors. I recognize the complexity of these modules within the overall Omeka-S structure…but this is a major hindrance to adoption of Omeka-S. There has to be a way to centralize the Module process and installation, making sure that dependencies are loaded when needed. Very very frustrating.

If it’s literally the same error then the problem is still with Log. I’d check that that file referenced in the error is present in your installation: modules/Log/vendor/autoload.php. If it’s not, you still have a “bad” copy.

ok. will give that a go