Tropy to Omeka S export problem

I tried to export items catalogued in Tropy using Omeka S(exhibit.cooponscitech.in) plugin with proper keys configured.

The same setting worked few months back.

However, with Tropy 1.11 and 1.12, i am getting the following error (from the log files in tropy).
It seems that the error is connected to laminas, which believe is used in Omeka development :

level":50,“time”:1669800955551,“type”:“renderer”,“name”:“project”,“plugin”:“tropy-plugin-omeka-v2.0.1”,“error”:"A plugin by the name “imageSize” was not found in the plugin manager Laminas\Mvc\Controller\PluginManager

pls help me resolve the error. I have setup the tropy, omeka s based workflow in order to organize the archive that we are deploying.

This is an issue for the Tropy developers, who need to update their code to work with the latest version of Omeka S. A post to their support forums should get that update moving.

Thanks @SharonLeon … will communicate it there now…

Hi! This is an error that happens in Omeka S, it’s just returned to Tropy via the API. I don’t think there is anything we can do client-side or did the API change in a significant way?

The error itself seems to be coming from another plugin (IIIF or ImageServer module) – maybe it’s just that this ‘imageSize’ plugin is legitimately missing?

Yeah, it looks like it would have to be a module on the Omeka S side of things… we don’t have an imageSize controller plugin in the core. It does seem likely that it’s related to the modules @inukshuk mentions… you might try disabling both, at least for diagnostic purposes.