Transcriptions won't save in MediaWiki 1.37.1

We upgraded our MediaWiki from 1.36.2 to 1.37.1 last week, and it broke the ability to save changes to transcriptions in Scripto. When I click the “Save transcription” button, it grays out and nothing ever happens. Does anyone know where to find the error log to try to diagnose this problem?

I can’t reproduce this. Open your browser’s debugger, click the “Save transcription” button, and see if there’s an error in the debugger’s console.

Thanks for looking at this. I rolled back our version of MediaWiki to 1.36.2 to verify the last version that allowed us to save changes to transcriptions, then upgraded incrementally this morning. We still had the ability to save after moving from 1.36.2 to 1.36.3, but it broke when I moved to 1.37.1. Here is the error that showed up in the console when I edited a transcription and tried to save:

POST https://transcribe.frick.org/scripto/index/page-action 500

send @ jquery.min.js:2

ajax @ jquery.min.js:2

S.<computed> @ jquery.min.js:2

(anonymous) @ 529:120

dispatch @ jquery.min.js:2

v.handle @ jquery.min.js:2

There appears to be a 500 Internal Server Error when attempting to save changes. There should be a way to get the actual error message in your debugger. In Chrome you’d be in the Network tab, click on the page with Status 500, and look at the Response.

It says:
The "token" parameter must be set.

You probably need to update your “MediaWiki cookie prefix” in your Scripto plugin’s configuration page.

We are using the prefix with the “dbname_dbprefix” and tried changing it to simply “dbname” but that broke the sign-in function. If there’s something more we should know updating the MW cookie prefix, kindly advise. For the record, we are using a forked version of Scripto, along with the following:

PHP Version 7.4.27
Apache Version 2.4.51
MediaWiki cookie prefix = $wgDBname . ‘_’ . $wgDBprefix

If it helps, here is the save error message with a few more details:

XHR POST https://transcribe.frick.org/scripto/index/page-action [HTTP/2 500 Internal Server Error 11643ms]
|POST|https://transcribe.frick.org/scripto/index/page-action|
Status
500
Internal Server Error
Version HTTP/2
Transferred 360 B (34 B size)
Referrer Policy strict-origin-when-cross-origin

Something is causing the server to timeout and it’s stuck waiting for something. I’m including a screenshot of the Request Timings here:

Perhaps it’s an incompatibility issue between our version of Scripto and MediaWiki 1.37.1 (i.e. Scripto needs fixing to match MW’s updates and there’s nothing necessarily wrong in MW)? We’d be curious to know if anyone specifically has this version of Scripto and MW 1.37.1 together with PHP 7.4 and is able to save without a problem.

I suspect that the fork you’re using does not include some of the more recent updates that fixed the login and token errors. You should ask the owner of the fork to merge in the changes.