Thumbnails don't appear after migration

We recently migrated our Omeka Classic instance from Reclaim shared hosting to Reclaim Cloud. Unfortunately in the process, our thumbnails are no longer appearing. ImageMagick is installed and seems to be working and the files themselves moved over to the new server. However we can’t seem to get thumbnails for existing items appear. They also don’t appear for newly uploaded items. Can anyone shed some light on what may be going on?

What are you seeing instead for existing items? Nothing at all or a “broken image” kind of thing?

It sounds like what would happen if the thumbnails were not moved over. You say they were, so it could be something like a permissions problem instead?

If you can share a link to the site showing the problem I might be able to say more about what’s happening, if there’s a 403 or 404 error, or just the thumbnails are not on the page at all.

The site is here: . The thumbnails don’t appear and instead we see the “no image” image or just nothing. I recall uploading all of the images manually, but didn’t think to check permissions. I will look into that tomorrow.

One more thing. Is there any chance I’ll have to re-import anything? We do have staff who plan to do work in Omeka and I don’t want to overwrite any of their efforts.

I can’t really see anything from there, it looks like maybe you have all your site’s content marked private? That wouldn’t be related to your problem but it just means I can’t see anything.

You probably don’t need to reimport things, just fix whatever the problem is with the files folder/subfolders.

I’ve made a test item public. My apologies for the oversight.

The problem could be having not installed ImageMagick Correctly. I’m not able to convert an image via the command line and PHP doesn’t seem to see ImageMagick. I’m going to work with our IT department this afternoon and if that is the problem, report back for future reference.

So, it looks like the item you shared is a new one? So it’s not helpful for looking at the issue you’re having with old thumbnails not appearing. If you could also make an old one that previously had thumbnails available that would be helpful.

As for new thumbnails, yes, I would imagine the problem is related to ImageMagick not being there, or needing to be configured differently. This problem is probably not the same as your problem with the old thumbnails.

Oh yeah that would definitely help. I’ve made two such items public.

And these used to have thumbnails? They both have the same appearance as the new one, which is what you get when a file just doesn’t have thumbnails at all. In other words, these items all look like ones that have never had thumbnails, not ones where the thumbnails are temporarily misplaced or unavailable.

When you moved this site, did you move the existing site/files/database or import from the old to the new? Importing involves re-making the thumbnails, so if that’s what you did then the ImageMagick issue you have actually could be the explanation for both of your problems.

I imported from old to new. While I can’t easily double check, I do think they had thumbnails. So your explanation makes sense. Unfortunately our college’s sys admin isn’t 100% sure what is going on either, but it may be down to Image Magick not supporting certain file formats.

Would the best way forward be to fix the Image Magick issue and then re-upload or re-import the images?

Between the information in this thread and working with the college systems administrator, we figured out the problem. When one installs ImageMagick from source as I did, one must also install the “delegates” to enable it to understand various file formats. I wasn’t aware and did not do so. Rather than installing them all one by one from source we installed a package named " libsdl2-image-2.0-0" from the Debian package repository. If anyone else runs across this thread, my recommendation would be to avoid installing ImageMagick from source.

The way forward seems to be to either re-run the import or manually re-upload the images. On that note I have one final question. If we re-run the import process will it overwrite changes made since the last time we ran it? Or will it just pull in old data and update the existing items?

You could try the Derivative Images plugin instead: it runs a background job to create/re-create thumbnails for all files uploaded to the site.

Oh I forgot about the plugin. Unfortunately it didn’t quite work. After I ran it, we now have a lot of boxes with a link (see below). If I click on the link there is a thumbnail. What does this mean?

It looks fine on the one item I can see on the public site. You might just need to reload and/or wait (the job may not have been finished creating the thumbnails yet when you looked).

Actually it turns out I didn’t run the plugin right. I only checked the box for thumbnails and not the other two boxes. This morning I didn’t check any boxes at all and it worked as advertised. You can see the results in the two items I made public on our site.

Thank you very much for your help. Our site is now fully migrated.

This topic was automatically closed after 250 days. New replies are no longer allowed.