The item page on my site shows missing id error

Hello!

I’ve installed a new Omeka S system and I created a new site. When I navigate to the item page of my new site i get the following error:
(apache2 mod_rewrite module is enabled, AllowOverride ALL directive is set)

Omeka S encountered an error

Zend\Router\Exception\InvalidArgumentException
Missing parameter “id”

Részletek

Zend\Router\Exception\InvalidArgumentException: Missing parameter “id” in /var/www/omeka/vendor/zendframework/zend-router/src/Http/Segment.php:309 Stack trace: #0 /var/www/omeka/vendor/zendframework/zend-router/src/Http/Segment.php(423): Zend\Router\Http\Segment->buildPath(Array, Array, false, false, Array) #1 /var/www/omeka/vendor/zendframework/zend-router/src/Http/TreeRouteStack.php(391): Zend\Router\Http\Segment->assemble(Array, Array) #2 /var/www/omeka/vendor/zendframework/zend-view/src/Helper/Url.php(106): Zend\Router\Http\TreeRouteStack->assemble(Array, Array) #3 [internal function]: Zend\View\Helper\Url->__invoke(‘iiifserver_pres…’, Array, Array) #4 /var/www/omeka/vendor/zendframework/zend-view/src/Renderer/PhpRenderer.php(397): call_user_func_array(Object(Zend\View\Helper\Url), Array) #5 /var/www/omeka/modules/UniversalViewer/src/View/Helper/UniversalViewer.php(96): Zend\View\Renderer\PhpRenderer->__call(‘url’, Array) #6 [internal function]: UniversalViewer\View\Helper\UniversalViewer->__invoke(Array) #7 /var/www/omeka/vendor/zendframework/zend-view/src/Renderer/PhpRenderer.php(397): call_user_func_array(Object(UniversalViewer\View\Helper\UniversalViewer), Array) #8 /var/www/omeka/modules/UniversalViewer/Module.php(139): Zend\View\Renderer\PhpRenderer->__call(‘universalViewer’, Array) #9 /var/www/omeka/vendor/zendframework/zend-eventmanager/src/EventManager.php(322): UniversalViewer\Module->handleViewBrowseAfterItem(Object(Zend\EventManager\Event)) #10 /var/www/omeka/vendor/zendframework/zend-eventmanager/src/EventManager.php(171): Zend\EventManager\EventManager->triggerListeners(Object(Zend\EventManager\Event)) #11 /var/www/omeka/application/src/View/Helper/Trigger.php(61): Zend\EventManager\EventManager->triggerEvent(Object(Zend\EventManager\Event)) #12 [internal function]: Omeka\View\Helper\Trigger->__invoke(‘view.browse.aft…’) #13 /var/www/omeka/vendor/zendframework/zend-view/src/Renderer/PhpRenderer.php(397): call_user_func_array(Object(Omeka\View\Helper\Trigger), Array) #14 /var/www/omeka/application/view/omeka/site/item/browse.phtml(71): Zend\View\Renderer\PhpRenderer->__call(‘trigger’, Array) #15 /var/www/omeka/vendor/zendframework/zend-view/src/Renderer/PhpRenderer.php(506): include(’/var/www/omeka/…’) #16 /var/www/omeka/vendor/zendframework/zend-view/src/View.php(207): Zend\View\Renderer\PhpRenderer->render(NULL) #17 /var/www/omeka/vendor/zendframework/zend-view/src/View.php(236): Zend\View\View->render(Object(Zend\View\Model\ViewModel)) #18 /var/www/omeka/vendor/zendframework/zend-view/src/View.php(200): Zend\View\View->renderChildren(Object(Zend\View\Model\ViewModel)) #19 /var/www/omeka/vendor/zendframework/zend-mvc/src/View/Http/DefaultRenderingStrategy.php(105): Zend\View\View->render(Object(Zend\View\Model\ViewModel)) #20 /var/www/omeka/vendor/zendframework/zend-eventmanager/src/EventManager.php(322): Zend\Mvc\View\Http\DefaultRenderingStrategy->render(Object(Zend\Mvc\MvcEvent)) #21 /var/www/omeka/vendor/zendframework/zend-eventmanager/src/EventManager.php(171): Zend\EventManager\EventManager->triggerListeners(Object(Zend\Mvc\MvcEvent)) #22 /var/www/omeka/vendor/zendframework/zend-mvc/src/Application.php(367): Zend\EventManager\EventManager->triggerEvent(Object(Zend\Mvc\MvcEvent)) #23 /var/www/omeka/vendor/zendframework/zend-mvc/src/Application.php(348): Zend\Mvc\Application->completeRequest(Object(Zend\Mvc\MvcEvent)) #24 /var/www/omeka/index.php(21): Zend\Mvc\Application->run() #25 {main}

What could cause my problem?
Thank you for your help!

This looks like it’s related to the IiifServer module in some way. I’m not an expert on that module, but you could check to see if disabling it eliminates the error or not.

It would also probably be helpful for you to share the version of Omeka S and of any modules that you’re using.