Tags page requires log in

We migrated one of our Omeka sites a while ago from v1 to the latest version. I thought all had gone well, but apparently the tags are completely broken now: Users are directed to log in to view them (http://unlhistory.unl.edu/exhibits/items/tags) and it seems like all the tags now have 0 items associated with them. I don’t have the old site up anymore, but I believe we still have an archive so could get that running if we want to see what it looked like before.

Is there an option somewhere that sets tags to public, or is this a deeper issue?

(I suspect part of the fix may be to get the old site installed and then go item by item and reassign the tags)

More details on links:

On this page there is a link that says “A cloud of all the keywords in use by the Omeka system may be viewed here.” - the student that created this exhibit says this link worked when she made the site, but now it requires a log in. if logged in, the page is a 404 error. Same with the other sources listed.

Looks like a couple small shifts might get it sorted out.

First, the link on the page you gave goes to http://unlhistory.unl.edu/exhibits/items/tags, which isn’t a valid url in Omeka 2 (I don’t recall how it worked in Omeka 1). But, http://unlhistory.unl.edu/exhibits/tags seems to be what you are looking for.

On the admin side, with the screenshot you gave, there’s a filter at the top for “Record Types”. By default, it gives info about tags on Items, but in that dropdown at the top you should be able to select “Exhibit” and it will give info about the tags on exhibits. Chances are it’ll still show lots of tags with 0 records, but it should also show the tags for Exhibits, with the correct number.

Thanks for the hint on the URL, it seems like we could do a search and replace to change them. However, there are still 0 items where I am pretty sure there were items before:

http://unlhistory.unl.edu/exhibits/items/browse?tags=uniforms became http://unlhistory.unl.edu/exhibits/browse?tags=uniforms

As to the tags: In the admin view, it appears everything remains exactly the same whether I choose “exhibit” or “item”

I’m afraid something went very wrong when we upgraded, but at this point we have new items so we need to try to fix in place. I’m waiting on phpmyadmin to get installed on that server so I can poke around a bit more to see how the tags are supposed to be associated with items and try to figure out what went wrong.

thanks for your help!

Yeah, phpmyadmin will be your friend, here!

The tables to look at will be tags and records_tags. Most of the interesting stuff will be in records_tags, which connects the tag to the item or exhibit or whatever.

Good luck