Switch from HTTP to HTTPS

Hello,

I have an old Omeka installation (1.5.3) and I want all my items, files and collections to be HTTPS. Currently, my front page is HTTPS but because some of my elements in there are not we don’t get that neat padlock :frowning: . I have tried several things: first setting ssl = ‘always’ in /application/config/config.ini but that broke almost all my links to collections, items (although some of them switched correctly to https). I have also tried to set $baseUrl = $baseRoot = “https://transcriu.bnc.cat”; in paths.php in the omeka folder but seems that nothing is working. Is there a settings option to fix this or am I missing something here?

I have followed these topics:
https://omeka.org/forums-legacy/topic/https/
https://forum.omeka.org/t/open-ssl-ssh-vs-https/5353
https://forum.omeka.org/t/omeka-installation-looks-terrible-since-https-switchover/5399/2

https://www.whynopadlock.com/results/86a8beee-4636-4c57-b0c2-74001a9c22cd

Thanks :slight_smile:

Newer versions of Omeka handle http vs. https more gracefully.

But, I’m not sure that’s really your issue here: As for your links being broken when you changed the SSL setting, that looks to be a problem with your server’s setup: it can’t serve anything besides the homepage on HTTPS. You’d minimally have to fix that problem to get HTTPS working properly here. Perhaps you have differing Apache settings like AllowOverride between the HTTP and HTTPS hosts?

Yeah, that was it, thanks @jflatnes :).

It was a configuration difference between the HTTP and the HTTPS hosts in Apache (concretely I had to modify AllowOverride= All in the directory /var/www and add an alias which was missing to my logo’s directory).

Best regards