Solr reindexed with new materials, but search results in Omeka not changing

I’m not sure what’s going on, but it’s not on the solr side. I reindexed via Omeka and if I go to the solr admin console I can run a query that finds the correct results. On the Omeka side, however, it’s as if the index never truly updated; I don’t find any of the new materials using the solr search. However, if I run the default/normal Omeka search then the items can be found.

The index are not the same and the links are different (mysite/solr-search and mysite/search), and you may have to update the main search field in the theme

1 Like

Hi Daniel, thanks for responding. I’m not quite I know what to change though? We’ve had the site up and running for a while, usually with no problem using the solr-search. I realize the indexes are different, but I’m not sure why the solr-search index doesn’t seem to work in Omeka all the time. If I run the search on the index outside of Omeka it works fine; it’s just the sitewide keyword search that uses solr-search that doesn’t seem to be updating. I tried to reindex via the solr plug-in, and in solr admin it shows the reindexing taking place – then I run the search via the solr admin console no problem: the correct results are shown. Then I go back to Omeka, I run the exact same search mysite/solr-search and it does not return the correct results.

Sorry, I can’t say more.

OK. Maybe someone else can. (@kloor do you have any ideas??) I’m attaching screenshots to show what I mean. We run solr 5.

When I run the query (“q”) in the solr admin console:

The results should be item 2409 first and foremost, because I’ve queried the identifier (which has higher relevance, and I’ve set that in the solr config file).

When I run the exact same query in Omeka using the sitewide solr-search via keyword I NEVER get item 2409:

It’s a shame that there doesn’t seem to be anyone working on developing the solr plug-in further. :frowning: Unfortunately it’s simply beyond our capacity here, but solr is far more powerful than the default Omeka search for non-Indo-European languages.

Could it be because item 2409 isn’t public? The Solr Search plugin wont include private items unless you are logged in to a user with permissions to view private items, and a setting is set within the Solr Search Results Configuration.

I haven’t done much testing with unicode characters outside of the ASCII range in Omeka, so I don’t know if that could be the issue. You may want to track down what query the plugin is actually executing. I could imagine the parenthesis causing issues as well depending on which Solr query parser you are using.


That seems to be it! Thank god… less work. I always thought I would be able to see all items regardless of status if I was logged in as super admin, but I guess not. I think I knew that but had forgotten? Thanks @kloor :slight_smile:

This topic was automatically closed after 250 days. New replies are no longer allowed.