Solr HTTP error?

Hello,
I am trying to configure my docker setup to run my omeka-s install (works fine) using Solr for indexing content (doesn’t work, yet).

I am using :

When I visit /admin/search-manager/solr, the column status does not say ok, but instead:

Solr HTTP error: Solr core is not available. 
Check config to get Solr core schema "http://localhost:8983/solr/omeka/schema".

If I check http://localhost:8983/solr/omeka/schema from the terminal in this docker container I get a proper config file, I have added manually the three required fields (“is_public_b”, “resource_name_s”, “site_id_is”), so I don’t understand why I can’t get this core to be seen as ok.

When trying to edit and save the core, I get the error described in Search Adapter for Solr configuration so that might be related but I subscribe that my issue happens earlier in the setup, that’s why I am creating this dedicated post.

In case someone has the same issue, it is because allow_url_fopen is disabled on my server, and SearchSolr is using file_get_contents to get the schema, crashing silently when allow_url_fopen is disabled.

In case you can’t change the setting on the server, it can be fixed by adding the lines in this merge request : https://gitlab.com/Daniel-KM/Omeka-S-module-SearchSolr/-/merge_requests/1/diffs