Simple Pages HTML editor not working


I am new to OMEKA so I apologise for for what is probably a basic issue.

When I select the tick box for the HTML editor to be available in the Simple Pages tab - the editor appears but I am unable to type anything at all into the window - nor do any of the buttons function. If I deselect the tick box the dialogue box returns to the non HTM text entry field.

Am i doing something really stupid? I have tried engaging and reengaging the HTML filter but that makes no difference.

I would appreciate some help. I am experimenting with OMEKA at the moment with a view to introducing it to my studnets for a University course in digital content management.

Can you tell us what versions of Omeka and Simple Pages you are running? Is this on your university’s servers?

First of all thanks for trying to help.

Omeka 2.5.1 - Simple pages 3.0.8.

I have done some investigating myself and it does not work on the university server however I have an installation on a commercial server and that works just fine.

The university tends to nail down permissions and whatnot so it maybe that some security setting that will be kept well out of my reach needs to be reset.

Are there any permissions that need to be specifically set to allow the HTML editor to work? I note that one of the other plugins I installed ‘drop box’ did need to permissions changed.

One other thing - when it fails a ghost HTML editor is rendered immediately below the text editor box - that one doesn’t work either.

I could also be something going awry in the javascript, which could be browser-dependent. So, what browser(s) are you using? And, have you tried this in more than one browser?

Good thought - just tried it in Safari - I was using Chrome - same result. I have sent a screen shot (by e-mail) of the ghost editing screen that appears immediately below it when it fails - I am not sure whether you got that - as i say this is only happening on my university server implementation of OMEKA.

This problem resurfaced after upgrading to Omeka 2.6 with Simple pages 3.08.

The fix!

Making a copy tinymce folder to tiny_mce. There is a call to this folder which is not there.

Step 1:
cd omekaFolder/application/views/scripts/javascripts/vendor

Step 2:
Verify that tinymce is there

Step 3:
cp -pr tinymce tiny_mce

Step 4:
cd tiny_mce

Step 5:
cp -rp tinymce.min.js tiny_mce.js

You should now be able to see the WSYWIG editor for simple pages again. I had to do this to 6 different Omeka installations. I believe this is a bug. Please fix soon!

Eastern Kentucky University

It’s not necessary to copy around files like that; just upgrade SimplePages to version 3.1. It was released alongside Omeka 2.6 for just this reason, and is actually the version bundled with Omeka 2.6.

1 Like

I created a new Omeka 2.6 installation with Simple Pages 3.1 and am not seeing the full set of editing options like in Omeka 2.5, just the most basic shown below. I have not been able to find a configuration setting to enable the other options like Increase Indent and Insert Image. I’m probably blind to something obvious, but would appreciate help if someone knows the answer.


I don’t think you are blind to something. It’s just part of a change we had to make for other updates to the HTML editor. We’ll investigate the possibility of adding them back in, and what tradeoffs would be involved.

Even if the buttons aren’t there, you can use any html tags in the code editing section (represented by <>), so long as they’re permitted in the Security Settings. For example, the img tag for Inserting Images.

1 Like

Hi all, finally upgraded us to Omeka 2.6.1 and love the new HTML feature! Unfortunately it does not seem to be working for metadata and especially Item Type Metadata Text. I’ve attached a screenshot. Thoughts? It’s working fine on Simple Pages and elsewhere.

Did you ever resolve this HTML issue? We also have several sites that upgraded to 2.6.1 and the HTML editor does not appear in Item Records (tags do work on their own). We are also looking into the reason behind this.

@akijas I had to deactivate Neatline Features to get it to work. I posted about it here. I don’t know whether or not that’s the same issue, but if you have Neatline plug-ins you could test by deactivating them one-by-one to see if it makes any difference.

Thanks @Amanda. Yes, we tried the same thing and that did the trick. But we will need the Neatline Features plugin so we need to figure out what is causing the issue with the HTML editor. I’ll post again with an update.

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.