Sharing buttons do not appear at the bottom of the item page when universal-viewer is activated

Hello,

We are using Omeka S 3.0.2, and installed Universal Viewer module 3.6.4.5 and Sharing module 1.2.0.

When set placing the sharing buttons at the bottom, the sharing buttons do not appear at the bottom of the item page when universal-viewer is activated, see screenshots below:

When I deactivate universal-viewer, the buttons display at the bottom of the item page.

Has anyone else had a similar issue and how did you solve it? Thanks!

To be clear here, your issue is that the buttons appear above the Universal Viewer, rather than below, right?

Correct, the sharing buttons appear above the Universal Viewer, they should be placed below the Viewer.
Thanks,

I believe that @Daniel_KM’s module BlocksDisposition is designed to solve these kinds of module-ordering issues, so you might try that out.

We’re also looking at adding features in a future release of Omeka S so you could reorder these and other parts of the “show” page out-of-the-box.

Thanks @jflatnes.

I installed BlocksDisposition and set settings for Universal Viewer and Sharing as:
image

The sharing buttons are disappeared, not showing in the item page, see screenshot:

I tested on Default and Foundation themes.