Scripto SyncProject Job Stuck at "Starting"

I’ve installed Omeka S without a problem and added a couple of items. I decided to experiment with the Scripto beta and, after installing the module it seemed like I was able to get a project set up with no problem. But when I tried adding 1 item to the project nothing seems to be happening. My job (“Scripto\Job\SyncProject”) is stuck at “Starting” and the Log is empty. I saw from the documentation that jobs may take a while to process, but I originally tried to sync the project about 16 hours ago with, again, just 1 item, so it seems like there ought to have been a resolution one way or the other by now. Any thoughts on what might be going on?

A job stuck in starting could mean that you need to configure Omeka’s PHP-CLI path in the config/local.config.php file.

Thanks for the recommendation. I’ve been able to install and use other modules, such as Mapping and Export. With help from my host (Reclaim) I’ve got the PHP-CLI path set at ‘/usr/local/bin/php’ (as described here: https://community.reclaimhosting.com/t/setting-the-php-cli-path-in-omeka-classic/231/5 – the initial post is for Omeka Classic, but the specific post linked is about setting the path for Omeka S). Any other ideas about what might be happening?

I suspect that the PHP-CLI path is either invalid or it points to a version of PHP that Omeka does not support. Omeka 2 requires at least PHP 7.1.0. I suggest contacting Reclaim about this.

1 Like

Thanks, I had an older version of PHP installed. Once I updated the job finished in just 1 second.