Scripto Logins not persisting

I’ve just set up a brand new installation of Scripto - a migration, really, but I built a new omeka and mediawiki and then imported my old transcription data.

I’m using a front end on a different subdomain that loads Scripto in an iframe.

Originally, mediawiki wasn’t logging the users’ IP addresses - instead, it was recording each change as being done by my IP address. This was solved with an installation instructions tweak: The instructions say to add:

$wgSquidServersNoPurge = array(‘127.0.0.1’);

but $wgSquidServers & $wgSquidServersNoPurge were removed in MediaWiki 1.35 and replaced with $wgCdnServers & $wgCdnServersNoPurge, so that line in the instructions should be corrected to say:

$wgCdnServersNoPurge = array(‘127.0.0.1’);

So that’s great. But, still, while the users are able to receive attribution, they aren’t able to log in. Clicking on Log In takes you to the log in, and you can add your username/password and successfully log in - but when you go back to the original transcription page, you aren’t logged in anymore.

Any thoughts?

You probably need to add a “MediaWiki cookie prefix” in the plugin’s configuration page. It’s most likely the name of your MediaWiki database.

I had MediaWiki cookie prefix set to the database name, and I confirmed $wgCookiePrefix wasn’t set in my LocalSettings.php - but it still wasn’t working.

So I went ahead and set $wgCookiePrefix to something in my LocalSettings.php, and updated Scripto with the new value, and it works now. Not sure what was getting in the way, but if anyone has this problem, it’'s worth a try. Thank you!