Save uploaded files in a large drive

Hi Omeka Team,

I need to save my uploaded files into a different drive than the drive of the installation.
I already tried changing my variables in xampp/omeka/bootstrap.php and there I changed my ‘FILES_DIR’ constant, with that solution the files are stored but can not be visible from omeka, even I went deeper and I changed also ‘WEB_RELATIVE_FILES’ and ‘WEB_FILES’ constant in the same bootstrap.php file and that was worst, the system crashed down.

The other solution that it comes to my mind is install the whole system with xampp in my large drive, but I want to query you if there is a better solution and how can I do it.

Thanks in advance.

You can change the location files are saved to without editing any of the PHP source of Omeka; there are configuration options for doing it.

On that page in particular you’d want to look at the localDir and webDir adapter options. Note: when you store the files somewhere else, it’s up to you to set things up so that they can be served to users by configuring the web server to serve files from that new location. This typically involves altering your Apache or other web server configuration.

Under Linux, people sometimes do things like this a different way by using symbolic links, but I don’t know that that would work for you on what’s presumably a Windows system.

1 Like

JFlatnes, Thanks a lot for your quick support. I have set these storage adapters:

storage.adapterOptions.localDir = "C:/NewFolder"
storage.adapterOptions.webDir = "http://localhost/omeka/files"

and are being saved properly but I am getting two related issues now :

  1. the files are with the GUID database name (I need to keep the original name)
  2. I can not see the file. When I click over the link to open the file (for instance a pdf file) does not open, does not do anything. And I don’t see why? I have changed my webDir value several times to see what is happening but still nothing. I know my webDir value is wrong but I don’t know which value put there.

Thanks once again.

I tried to explain this in my previous message, but if you’re going to store your files outside your web server’s normal document root, as you’re probably doing here, you have to configure some setup for having those files served. There’s no “right” web directory for this setup, it’s dependent on how you have it set up. It could be a different folder, a different domain name, lots of things. It may be simpler for you to just install directly on the larger drive, as you suggested.

The files having the hex-string names is just a feature of Omeka. There’s no official method for disabling that, though there are options with plugins. I don’t know if those options have any issues running on Windows, though.

1 Like

Yes jflatnes, I want to store my files outside of my web server’s normal document root…Can you guide me in you have to configure this setup for having those files served? Still I think this solution is better than install the system in my large drive.

Any suggestion of omeka plugins to get the original name of the uploaded files? …Thanks

I linked a plugin that does that on the word “plugins” in my previous message.

About serving from different locations, that goes a little beyond the scope of Omeka support that’s the focus of the forums here and more into Apache support. The best I can do here I think is to direct you to the Apache documentation about this topic.

1 Like

Thanks a lot for your support Jflatnes. I will continue fixing my environment in order to get what I need, You really moved me forward in this. Thanks once again

I Have the same Problem - so it would be great to let me know if you find a working solution - i’ll let you know when i find one - Maybe working with a “symlink” could be a solution.

1 Like

Hi @jan, the solution is configure the omeka settings files , you just need to set up the storage properties that is described here, this are the configuration options which @jflatnes explained me in his first reply. When you set that storage properties the files will be saved in your new drive path

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.