RestrictedSites - can't make it work


#1

Hello! I’m running Omeka S v1.2.0 (until Reclaim Hosting updates it) and I’m trying to make RestrictedSites v.0.5 work.

I have two sites - one is a public-facing site and the default (when you go to the site’s root, you get this site). That’s working fine. I also have a second site that I would like to use as an internal database with additional material that I don’t want on the public site. Again, it’s all set up, and is working like a charm. I have it set to private, so in order for my staff to see it, they have to log into the administrative side, choose “sites”, and open the site from there. I’d like to make it so that I can give them a direct link to the internal site, they click on it, be given a prompt to log in, and then they’re directed directly to the site, bypassing the back-end administrative section. After looking into it, it looked like the RestrictedSites module would do the trick.

I installed and activated the module, added my users as viewers to the user list within the site settings, checked the “Restrict access to site user list” checkbox in the internal site’s settings and made the site visible (eyeball is not crossed out). In theory, if I understand the module correctly, now when I go to “www.mysite.com/s/internalsite” and am not currently logged in, it should bring me to a login screen and then on to my site. Instead, I continue to get the “Not found” Omeka error message. Am I missing something, or should it be working?

I’m using the Center Row (1.2.0) theme. Other modules that I have activated are:
Comment (3.1.5)
CSV Import (1.1.0)
Custom Vocab (1.1.0)
Google Analytics (1.0.1)
Metadata Browse (1.1.2)
PDF Embed (1.1.0)
Value Suggest (1.1.0)

Thank you all so much!


#2

Hello morgannis,

Thanks for trying out the module, it’s still in early development but I use it daily on my own installation. Your understanding of its features is correct.
There was a bug that I was able to correct thanks to your feedback. You should update the module and try again.

Have a nice day

Laurent


#3

Amazing! Thank you so much, both for your fantastic module and for your quick fix. It’s so much appreciated, and worked like a treat! :slightly_smiling_face:

Happy holidays!
Morgannis