Report Plugin Error

I’m having a problem with the Report Plugin. After generating a report, it seems to be stuck “In Progress”.

We tried deactivating and re-activating the Reports plugin. But that did not help clear the existing reports “in-progress” error.

Reclaim Hosting Tech Support even created a “Test report” on our site to see if there were any issues with the filters in the report but got the same result with the report stuck “in-progress”. There are no issues on the server as well.

It’s a pity that there is no way to create a simple report in Omeka. Can someone please advise? I think there is an issue with the actual Reports Plugin that needs amending.

A job that’s “stuck” on in progress probably encountered a fatal error. Enabling and checking the Omeka log, or maybe more likely looking for errors from PHP itself, would be good ideas for where to look for information on what’s happening. Often on Reclaim those PHP errors are stored in a file named “error_log,” which might be located in your root Omeka folder (or possibly inside application/scripts).

Also, I’m not sure if you’ve set the PHP path as is often required on Reclaim, that’s a good thing to check first if you haven’t already.