Public site not accessible


#1

Trying to view Public Site I’m redirected to home page of my local web server (apache2+linux raspian).
I’ve been able to access install page manually typing http:///install/install.php and evrything has been compelted in the right way.
I can reach admin page only typing http:///admin/index.php.
I’m able to add collections and items but when I click form collection page “view public site” no page is found showing “The requested URL /collections/show/1 was not found on this server”.
It seems that some links are not correct.
Any suggestion on how to fix this problem, please?


Collection viewer: endpoint may not support REST API
#2

After some attempts, I’ve finally found that I should always put index.php in the url.
For example: If I click in the collection page “view public site” no page is found showing “The requested URL /collections/show/1 was not found on this server" BUT if I modify the URL in this way http:///index.php/collections/show/1 it works.
Is it normal ?


#3

This sounds like the typical symptoms of a mod_rewrite or .htaccess issue…

That “direct access” method you used for the installer bypasses the mod_rewrite check but won’t actually fix your problem. Usually bypassing the check is a bad idea, unless you’re in a fairly rare type of situation where the check is broken but rewrite is actually working.

Make sure mod_rewrite is enabled for Apache, that AllowOverride for your web directory is set to On (this is in Apache’s config file), and that the .htaccess file is present in your Omeka directory.


#4

After having set AllowOverride to All (it was none) for my web directories in apache2.conf now it works !
Thanks a lot.