Problems with Omeka S csv import and viewability in the Browse page

Hi I’m trying to import a small sample of data via the csv import tool and strange things are happening.

  1. Even though they are added to a site and the item details panel shows that they are, in fact, added to a site, they do not show up in browse, even if I add them to an item set and add the item set to the site, or when I make a browse tab that specifically queries the item set.

  2. The lat/long importing is working but the zoom level seems to be completely ignored. Worse, I can’t figure out where to set that zoom level in the tool.

Sorry, I’m very new to Omeka S though I have a lot of experience with Omeka Classic. I’m probably missing something very basic.


Nobody can view them in the site? I’m trying to rule out, for example, that the items are just marked Private.

Yeah, No one can see them even though they are definitely public. It’s very strange. I can place them on another site and the items appear there, but never on this new site I created.

I found the answer to why things are not showing up.

I had “Restrict Search to Attached Items” checked. I have no idea what that means. Where do you attach an item? If it is added to the site is that not attached? They should clarify that in the interface or just delete that box. I think I checked it as I wanted the site to search only the items specifically included in it, not all of the possible items. Argh. It’s very annoying.

I still have the crazy zoom/mapping problem if you have any ideas on that.

Sites always include only the things assigned to them.

“Attached” items there in that setting means items that are being used on a page (where they’re called “Attachments”).

1 Like

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.