Problem with File Sideload

When 4.0.1 came out we decided to uninstall (using Installatron in Reclaim) and start fresh. We left the sideload directory where it was (see attached), inside the directory where Omeka S was installed but not in the modules directory, and now it won’t recognize the path.

Should I just create a new directory for sideload?

What do you mean by “it won’t recognize the path”? Do you see an error message? Does Sideload’s file drop-down not contain any files?

Could it be that some directory permissions were changed during the upgrade process? Your web server must have at least read access to the directory.

It won’t accept the path when I configure the module.
I get these error messages:

  • The provided sideload directory is not a directory or does not have sufficient permissions.
  • There was a problem during configuration

The directory has permissions of 0755

Do you have “Delete sideloaded file?” checked? If so, your web server must also have write permission on the directory.

Otherwise, I’m not sure what’s going on. It’s a simple check to see if the directory is executable and readable, which matches 755.

No, I did not check the “delete sideloaded files” option. We were able to FTP files into the directory.

Strange. What’s the version number of your File Sideload? You could try to temporarily change the permissions on that directory to 777 and see if it is indeed a permissions issue. Be sure to put it back to 755 after you’re done.

I’m still stumped! I created a new subdomain, installed Omeka S 4.0.1, then installed FileSideload module 1.7.1 to no avail. Uninstalled and deleted and tried 1.7.0 - same error:

  • The provided sideload directory is not a directory or does not have sufficient permissions.
  • There was a problem during configuration

I contacted Reclaim and they did not see any problem with the directory permissions:
“Since you mention the directory not being recognized I’ve run a script that fixes file and directory permissions across the account just in case this was the problem.”

Are you sure you’re giving the correct path to the folder in the File Sideload module configuration?

I made a new sideload directory on the root / same level as the new Omeka S installation and now it is happy. Maybe something about uninstalling and reinstalling in the same directory caused a problem?

Turns out there were still permissions issues. At Reclaim’s suggestion I moved the sideload directory into the Omeka S installation and the module won’t recognize the new configuration path. It’s like the original configuration got hardwired. Is that expected?

The configuration of what folder you’re using doesn’t get saved anywhere but in that entry you can see and edit for the module.

I would generally point the finger at permissions issues if a particular path is not working and others are, though I know you’ve said you’ve looked at permissions quite a bit already.

There really shouldn’t be a reason you need to have the sideload folder inside the Omeka S folder itself. What permissions issues were you having this time?

Could you look at my settings and spreadsheet snippets and see what jumps out at you? I’ve got screenshots, job details, and logs from two slightly different recent failures.

Thank you!

Job26-red_Working_version.pdf (129.9 KB)
job26-ErrorLog.pdf (929.8 KB)
Job27-ErrorLog.pdf (141.3 KB)
Job27-redTestCSV-3.pdf (125.2 KB)
omekaSproblem.pdf (283.8 KB)

There’s a lot there, but both of these seemed to have a similar problem: it looks like you have multiple files in each “filepath” cell, but you’re not choosing the “multivalue” option for that column when setting up the import. The “wrench” options menu for a column has a setting you need to enable for a column’s values to be treated as multivalue. When done correctly, the main “mapping” screen of the importer will show “Multivalue” in the Options section for the column.

Thanks - I did set the multivalue separator on the Basic Settings screen - is there more than one place to to this?

Whew - I found it ! :sweat_smile: