Problem to upload files with Omeka 2.4.1

I made fresh install with Omeka 2.4.1 and install process was ok but when i try to upload banner image i get error:

Omeka has encountered an error
Unable to store file.

Omeka_Storage_Exception: Unable to store file. in /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Omeka/Storage/Adapter/Filesystem.php:119
Stack trace:
#0 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Omeka/Storage.php(67): Omeka_Storage_Adapter_Filesystem->store('/tmp/35bdc1e2ff...', 'theme_uploads/3...')
#1 /var/www/fs4/1/kirjasto/public_html/fi/application/controllers/helpers/ThemeConfiguration.php(108): Omeka_Storage->__call('store', Array)
#2 /var/www/fs4/1/kirjasto/public_html/fi/application/controllers/helpers/ThemeConfiguration.php(55): Omeka_Controller_Action_Helper_ThemeConfiguration->_processFileElement(Object(Zend_Form_Element_File))
#3 /var/www/fs4/1/kirjasto/public_html/fi/application/controllers/ThemesController.php(82): Omeka_Controller_Action_Helper_ThemeConfiguration->processForm(Object(Omeka_Form_ThemeConfiguration), Array, Array)
#4 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Zend/Controller/Action.php(516): ThemesController->configAction()
#5 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch('configAction')
#6 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#7 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch()
#8 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Zend/Application.php(384): Zend_Application_Bootstrap_Bootstrap->run()
#9 /var/www/fs4/1/kirjasto/public_html/fi/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#10 /var/www/fs4/1/kirjasto/public_html/fi/admin/index.php(28): Omeka_Application->run()
#11 {main}

But i can find new file att files folder -> rights are ok.

If i try to upload any file to item - nothing happens.

I have tried to search similar cases but not found anything that helps. What i can do?

Omeka is hosted at webhotel but i can give my own php settings.

You say “nothing happens” in the case of uploading files to items. Do you mean literally nothing (i.e., the file doesn’t get uploaded and there’s no error message), or do you mean there’s no problem?

The error message you pasted is basically the standard one when the permissions are wrong on the files folder or one of its subfolders, or you’re out of space on the disk.

When i try to attach some file to item (or upload to image to theme) -> i get error and file wont appear to under files folder. Under weekend i think that when i try to upload logo to theme -> i get error and file appear to under files folder (but any more).

So at root folder can be found files-folder where all uploaded files should be stored? files and all under that has 775/777 rights -> should have enough rights to upload? or should i give some extra rights to somehere?

Files folder and all under that has rights enough rights (777 for testing). Under theme_uploads folder i upload works -> can be upload but Omeka gives same error and files has right 644.

Could permission problem be linked to tmp-folder? or its location?

The step Omeka’s saying it can’t do is moving the file from the temp directory into Omeka’s files directory. Generally that means the temp folder permissions are not the problem, since the process would fail earlier.

You said the files get created with 644 permissions: are there files being created in the files/theme_uploads folder? If they are, do they have the right size and/or content? We throw this error when the system tells us it couldn’t move the file, so usually it means there’s no file there.

I have hosted another Omeka installation at own Ubuntu-server. There uploaded files owned by www-data. That newest Omeka installation has “ftp-user” as owner that could explain problem?