Problem importing PROV-O ontology as new vocabulary

I’m trying to add the W3C PROV ontology as new vocabulary, but the import fails without a descriptive error message or log file entry. I’ve tried uploading via URL and file in combination with file formats [autodetect], Turtle and RDF/XML. All give the same error.

I’m using Omeka v4.0.4. Ran into this problem after updating the vocabulary without a problem.

Strange. I successfully imported the vocabulary with the following data:

Namespace URI:
Vocabulary URL:
File format: [Autodetect]

Due to a recent security issue, we had reason to make that error message generic. We recognize that this makes it difficult to troubleshoot, so we have a pull request that makes the message more specific. In your case it’s likely that Omeka’s RDF library couldn’t load the vocabulary from the URL. Could you have intermittent connection problems?

I used the namespace URI (with -o) which Omeka S doesn’t accept. The URI (which you suggested and actually is the correct one) is accepted with no problem!