Plugin message, Please upgrade doesn't go away after upgrade

Hi All,

I am upgrading Omeka, this time from 1.4.x to 1.5x. When I go to admin/plug-in page it says,

You have a new version of Contribution. Please upgrade!
You have a new version of CSV Import. Please upgrade!

When I press the upgrade button, it says upgrade was successful, but the “Please upgrade!” message doesn’t go away for either Contribution or CSV Import.

I am running Omeka 1.5, Contribution Version 2.2.1 and CSV Import 1.3.4


Those are some pretty old versions you’re dealing with…

I know you said in a previous message you had problems with bigger jumps forward, like going straight to 2.5. What kind of problems did you have? Support for these older versions is a little harder to muster because of lack of running examples and expertise.

As for these specific problems, I suppose there’s some error occurring but not being recorded. Have you tried to enable Omeka’s error logging in application/config/config.ini and then checking to see if anything is logged?

Thanks for the reply.

Previous update attempt can be found in the legacy forums, located @ url,

Thank you

I did notice that during the upgrade that simple items like site name wasn’t preserved :frowning:
Nothing fancy here! Here is the site info.

Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Role: super

Omeka: 1.5.3
PHP: 5.5.33 (apache2handler)
OS: Linux 2.6.32-642.11.1.el6.cse.x86_64 x86_64
MySQL Server: 5.0.92
MySQL Client: 5.0.92
Apache: Apache/2.2.22 (Unix) DAV/2 mod_ssl/2.2.22 OpenSSL/1.0.0o PHP/5.5.33

PHP Extensions
Regular: apache2handler, bz2, calendar, Core, ctype, curl, date, dom, ereg, fileinfo, filter, ftp, gd, gettext, hash, iconv, imap, intl, json, libxml, mbstring, mcrypt, mysql, mysqli, oci8, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, snmp, soap, sockets, SPL, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter, zip, zlib

Contribution: 2.2
CsvImport: 1.3
ExhibitBuilder: 1.2
HtmlPurifier: 0.1
SimpleContactForm: 0.3
SimplePages: 1.3

Minimalist Omeka Theme:1.2
Rhythm: 1.3 (current)
Seasons: 1.3
Thanks, Roy: 1.5


I tried to move from 1.5.3 to 2.0.4 and when I tried to upgrade the plug-in ExhibitBuilder 2.0.4 I get the following error. These are the reasons I alway had to fall back to 1.3.2, but I need to move up to the lates

Previous to this error the database was upgraded successfully.

Omeka has encountered an error
Mysqli statement execute error : Duplicate key name ‘exhibit_id_parent_id_slug’

#0 /eecs/home/museum/www/omeka/application/libraries/Zend/Db/Statement.php(303): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /eecs/home/museum/www/omeka/application/libraries/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 [internal function]: Zend_Db_Adapter_Abstract->query(‘ALTER TABLE om...') #3 /eecs/home/museum/www/omeka/application/libraries/Omeka/Db.php(79): call_user_func_array(Array, Array) #4 /eecs/home/museum/www/omeka/plugins/ExhibitBuilder/functions.php(198): Omeka_Db->__call('query', Array) #5 /eecs/home/museum/www/omeka/plugins/ExhibitBuilder/functions.php(198): Omeka_Db->query('ALTER TABLEom…’)
#6 [internal function]: exhibit_builder_upgrade(Array)
#7 /eecs/home/museum/www/omeka/application/libraries/Omeka/Plugin/Broker.php(145): call_user_func(‘exhibit_builder…’, Array)
#8 /eecs/home/museum/www/omeka/application/libraries/Omeka/Plugin/Installer.php(97): Omeka_Plugin_Broker->callHook(‘upgrade’, Array, Object(Plugin))
#9 /eecs/home/museum/www/omeka/application/controllers/PluginsController.php(185): Omeka_Plugin_Installer->upgrade(Object(Plugin))
#10 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Action.php(516): PluginsController->upgradeAction()
#11 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch(‘upgradeAction’)
#12 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#13 /eecs/home/museum/www/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#14 /eecs/home/museum/www/omeka/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#15 /eecs/home/museum/www/omeka/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#16 /eecs/home/museum/www/omeka/admin/index.php(28): Omeka_Application->run()
#17 {main}

Here is the error for SImplePages v2.0.2

Omeka has encountered an error
Error in configuring plugin named “Simple Pages”. Missing config and/or config_form hook(s).

#0 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Action.php(516): PluginsController->configAction()
#1 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch(‘configAction’)
#2 /eecs/home/museum/www/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#3 /eecs/home/museum/www/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#4 /eecs/home/museum/www/omeka/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#5 /eecs/home/museum/www/omeka/application/libraries/Omeka/Application.php(79): Zend_Application->run()
#6 /eecs/home/museum/www/omeka/admin/index.php(28): Omeka_Application->run()
#7 {main}


Just like on the old forums, the symptoms you’re describing are fairly baffling. Even when they’re slightly different they never seem to quite make sense…

You said you lost even basic settings like the site name when you upgraded. What was the name instead, just nothing? We don’t really have any default for the site name. I’ve also never heard of problems with that kind of setting in an upgrade. Which “leg” of the upgrade did this happen on? I’m wondering if we’re dealing with corrupted or faulty database dumps/backups and/or bad copies of core or plugin files. It’s possible your problem goes back to your 1.3.2 dump, explaining how you always run into problems moving forward.

Anyway, right now you’re not getting any errors at all, just the “upgrade successful” message but no actual upgrade?


Here is the site:

Before the upgrade the site_title was “York University Computer Museum” after the upgrade it is “0”. I have a MySQL dump before and after the upgrade, so I can go back and check. If I restore back to Omeka 1.3.2 everything would work without any issues.

Right now, the plug-ins are not upgrading. When I click the upgrade button I get the error messages I listed in the previous e-mail. The database is upgrade successfully.

I am baffled because Omeka is so widely used, yet my issues seem to be so unique! Just for the record, what is the recommended upgraded path from 1.3.2 to to 2.5?

I wonder if I should try the upgrade in a VM, do you have a preferred Linux Distro? I am thinking about CentOS/RHEL 7.3 for the long term support.

Thank you

The feeling is mutual.

In general, I think it’s best to go all the way to your destination in one step. Sometimes later versions fix problems with the upgrade or are just better at running on current systems.

It’s clear from your link that it hasn’t upgraded properly as you describe: the site title is gone, there’s no theme selected, and that’s just what’s immediately visible. It kind of looks as if the entire options table was lost or corrupted (as that’s where both the site title and current theme are stored).


Just an update for everyone. I transfered Omeka 1.3.2 along with the database to a VM running CentOS 7.3 and I started the update process again.

I followed the following update path; 1.3.2 -> 1.5.3 > 2.0.4 -> 2.1.4 -> 2.2.2 -> 2.3.1 -> 2.4.1 -> 2.5

I likely didn’t need to do so many steps, I wanted to take small steps since I was deal with a really old install from February 23, 2011. That is exactly 6 years to the day! :smile: The end result is a working system running 2.5 and I didn’t run into any error during the upgrades. Everything just worked

System Information:
Omeka: 2.5
PHP: 5.4.16 (apache2handler)
OS: Linux 3.10.0-514.6.1.el7.x86_64 x86_64
MySQL Server: 5.6.35
MySQL Client: 5.6.35
Apache: Apache/2.4.6 (CentOS) OpenSSL/1.0.1e-fips mod_fcgid/2.3.9 PHP/5.4.16

PHP Extensions:
Regular apache2handler, bz2, calendar, Core, ctype, curl, date, ereg, exif, fileinfo, filter, ftp, gettext, gmp, hash, iconv, json, libxml, mhash, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, Reflection, session, shmop, SimpleXML, sockets, SPL, sqlite3, standard, tokenizer, xml, zip, zlib

Contribution: 3.1.0
CsvImport: 2.0.4
ExhibitBuilder: 3.3.3
GuestUser : 1.1.1
HtmlPurifier: 0.1 (inactive)
SimpleContactForm: 0.5
SimplePages: 3.0.8

berlin: 2.4 (current)
default: 2.4
rhythm: 2.2
seasons: 2.4

Glad to hear that you finally found a process that worked.

I’m still left wondering what was happening with your previous problems, but it sounds like the VM was a good solution for you.