Pictures do not upload; I only get a generic image placeholder

I’m trying to upload images to both my exhibits and items, and while they upload, I cannot see the image. I only get a generic image picture, so to actually view it on my site, I have to click into the placeholder and onto a link, where I’m redirected to a completely different page to see the image.
I’ve tried to look through the forums to find a solution, but I truly have no idea what I’m doing, and all the talk of different codes has me completely lost. Is there a simple solution to this problem?

If you go to Settings - General and click the green Test button under the ImageMagick Directory Path field, what does it say?

It says "The ImageMagick directory path does not work."
I tried inputting a few things I’ve seen across the forums, but I still got the same message.

ImageMagick not working is why you’re not getting thumbnails.

You should contact your hosting provider and ask them what the right path is.

Ah, great thanks for the help!