PDFs thumbnails not shown

Hello everyone. I would like to know why Omeka is not showing the thumbnails of the PDFs files that I have recently uploaded, only the old items files are shown correctly. Thumbnails in onother format are Ok. I’m using Omeka 3.0.2.
Thank you!

Are thumbnails for your PDFs being created? If not, you can use the Derivative Images plugin to generate thumbnails for anything that didn’t work right on upload:

If they are being created (i.e. you can see them in the admin views) but just not displaying on public pages, let me know.

I think what you’re saying is that you’re uploading new files in other formats and those are generating thumbnails fine, so it’s probably not a new imagemagick or php version issue. Still, if you could paste your Omeka installation’s System Information page here, that would be helpful.

Thank you AllanaMayer,
Pdf thumnails are not created, I can´t see them in public or admin side.
Ive installed the Derivative Images plugin, but it still doesnt work.
There is no problem with jpg, png or any other formats.

Browser Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
Role super
Omeka 3.0.2
PHP 7.3.29-1~deb10u1 (apache2handler)
OS Linux 4.19.0-17-amd64 x86_64
MySQL Server 10.3.29
MySQL Client mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
Apache Apache/2.4.38 (Debian)
PHP Extensions
Regular apache2handler, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, ftp, gettext, hash, iconv, imagick, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, Phar, posix, readline, Reflection, session, shmop, SimpleXML, sockets, sodium, solr, SPL, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, Zend OPcache, zlib
Zend Zend OPcache
AccessibilityPlus 0.1 (inactive)
AdminImages 1.3
AvantCommon 2.1.0
AvantRelationships 2.0.0
AvantSearch 2.0.0 (inactive)
CSSEditor 1.1
Coins 2.1
CollectionTree 2.1
Commenting 2.4
ConnectedCarousel 2.2 (inactive)
Contribution 3.3
CsvExport 1.0.1
CsvImport 2.0.5
DerivativeImages 2.0
DocsViewer 2.2 (inactive)
DublinCoreExtended 2.2
DuplicateItem 0.1
ExhibitBuilder 3.5
Export 0.1.0
Facets 2.8.1
GDriveLinks 1.0.0
Geolocation 2.2.6
GoogleAnalytics 1.3-2.0
GuestUser 1.2
HideElements 1.3
ItemDuplicator 1.3
ItemOrder 2.0.1
LcSuggest 2.0.3
LimitVisibilityToOwn 1.2 (inactive)
LocaleSwitcher 0.2.1
MlaCitations 1.1
Neatline 2.6.1
NeatlineSimile 2.0.4
OaiPmhRepository 2.1.1
PdfEmbed 1.0.1
RecordRelations 2.0.1
Reference 2.7
Reports 2.0.2
SearchByMetadata 1.2.1 (inactive)
ShortcodeCarousel 1.0.1
SimpleContactForm 0.5
SimplePages 3.2
SimpleVocab 2.1 (inactive)
Sitemap 2.3
SocialBookmarking 2.0.3
UserProfiles 1.1.1
WikipediaCitations 1.0 (inactive)
ZoteroImport 2.1
berlin 2.7.2 (current)
bigstuff 1.0
centerrow 1.6
cville_rally_theme 0.0.1
default 2.6.5
seasons 2.6.2

One suggestion is there might be a policy issue for PDFs specifically with imagemagick:

I think you could try switching the thumbnailer utility and see if that helps, if you can’t edit the policy directly:

I’m having the same issue. Haven’t changed anything whatsoever, haven’t even yet upgraded to the latest Omeka version, but went to upload a bunch of PDFs for a new collection and no thumbnails are being generated/showing. Was a solution found for this?

ETA: so thumbnails are actually being generated, I think, according to running convert at command line on a test file. So what I’m seeing are actually white/blank images.

ImageMagick version on the server is 6.9.10-68
Ghostscript 9.25

ETA2: so I tried it with another PDF, and it rendered the thumbnail correctly… the issue seems to be something between Imagemagick and the way these particular PDFs are rendered in ABBYY. Which is odd since previous PDFs were also done in ABBYY… but at least I can say it’s got nothing to do with Omeka, rather with Imagemagick and ABBYY (and/or particular PDFs).

One thing that can happen with some server setups is that PDFs with JPEG2000 images embedded don’t work… this is typically down to the Ghostscript side of things.

When a PDF is all scanned images, then the images not loading tends to result in “blank white page” thumbnails.

There are tools you can use to check the format of images embedded in a PDF, or you could share a test one here and I can check it. But this is the similar issue to yours I’ve seen before, at any rate.

1 Like

Hi @jflatnes I’m guessing it’s exactly that. Is this a server-side fix to Ghostscript? I have 80 PDFs like this, and because they were images brought into ABBYY and OCR’ed, it wouldn’t be easy (manpower) to have them all be re-done.

In the past when I’ve encountered this problem, the issue was that the version of Ghostscript installed was using the “jasper” library to decode JPEG2000 images, rather than “openjpeg”.

The solution has been to upgrade or replace Ghostscript with a newer/different version that uses openjpeg.

That’s of course, only if this is in fact the issue.

1 Like

Is there a command to figure out which library it’s using? I’m googling unsuccessfully at the moment…

The output of ldd /usr/bin/gs would tell you what libraries Ghostscript is linked to, which should indicate what, if any, JPEG2000 support is being used. I believe you’d be looking for “libjasper” or “libopenjp2” in that output.

1 Like

So the original files are actually jbig2, not jpeg2000, which apparently is a bigger problem or has been with Imagemagick concerning PDFs (but not actual images?). Although PDFs themselves seem fine, it’s just the thumbnails causing issues. And now I’m wondering if this jbig2 thing is because the files used ABBYY FineReader to save/export as PDFs and that is compressing them into jbig2… I’m investigating ABBYY settings (EDIT: yes it’s exactly that as ABBYY saves b and w PDF images in jbig2 (lossless) format) and, in the meantime, I’ve posted a message with the Imagemagick folks over at Github to explain our situation:

But if you’ve got other ideas or know anything about this issue, happy to hear of any solutions!

On ImageMagick: the way ImageMagick handles PDFs is basically that it just hands them off to Ghostscript to turn them into an image, then does the image processing as normal. So for anything embedded inside the PDF like these images, it’s Ghostscript’s support that matters, not ImageMagick’s.

1 Like

Just wanted to follow up on this and say that updating Ghostscript solved the problem. I thought we had 9.25, but it was actually an older version and should have been updated a while ago on the server, but for some reason it wasn’t (I didn’t check the error files). Ghostscript 9.25 definitely works with JBIG2, whereas all I can say is that (some?) earlier versions didn’t/don’t.

1 Like

Thank you for the update! That’s useful to know.