Page not found Reason: error-router-no-match

Hi all,

I’ve been wrestling with an Omeka S install on a virtual server for a few days (mostly it’s because I’m rusty at this). I finally got a new error but this one is stumping me and I haven’t found a question/answer that seems to match my circumstances here (although apologies if I overlooked it).

The error I’m currently getting at [mybaseurl]/my-omeka-s, [mybaseurl]/my-omeka-s/install, and [mybaseurl]/my-omeka-s/admin is “Page not found Reason: error-router-no-match”

I’ve done the following at this point:

  • Set up a virtual server running Ubuntu 20.04, Apache, MySQL, PHP
  • Set up a database for Omeka using PHPMyAdmin (I didn’t give the database any tables, since I think those get created when I finish the install process through the browser, but maybe I goofed that up?)
  • Edited /config/database.ini to include database credentials
  • Updated .htaccess and enabled mod_rewrite
  • Created omeka-s.conf and added it to apache2/sites-available
  • Confirmed that if I add “test” to the top of my .htaccess file I get an Internal Server Error (saw that suggestion in a thread where someone was getting a 404 and that was helpful)
  • Confirmed that I am using the Omeka S zip file from the omeka downloads page, rather than the one from GitHub

Has anyone seen this before, and/or do you have any suggestions on where I might start troubleshooting this? I may be missing something super obvious but I just can’t get that install screen to display!

Thanks in advance,

The “error-router-no-match” error is coming from Omeka S itself, so at some level it’s running.

Does your browser seem to try to redirect you at any of those URLs you tried? Or does the URL in the browser bar just stay the same?

I’m wondering if maybe the issue is in your “omeka-s.conf” file for Apache. What does that look like?

I was hoping that’s what it meant, and there was definitely some fist-pumping in the air when I got to this error because it seemed like huge progress!

My browser is not trying to redirect me - it stays the same, and I get the same error screen each time.

Here’s what my omeka-s.conf file looks like:

<VirtualHost *:80>
	ServerName omeka-s
        DocumentRoot /var/www/html/omeka-s

        <Directory /var/www/html/omeka-s/>
            Options Indexes FollowSymLinks
            AllowOverride All
            Require all granted

        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined

        <IfModule mod_dir.c>
            DirectoryIndex index.php index.cgi index.html index.xhtml index.htm


I have wondered if omeka-s should be at the same level as html, but all the configuration seems to be set up consistently for it to be inside html (read: I think I configured everything correctly), and I did some testing yesterday which seemed to indicate I had it at the right level.

And how do you get to this Omeka S install? Meaning, what’s the URL you’re using?

The way you have it set up here is using name-based virtual hosting, so it would be something like http://omeka-s/ and you’d need to have DNS or a hosts file set up to make “omeka-s” map to your server’s IP.

If you’re just putting the folder inside /var/www/html anyway, I’m not sure you really want to define an extra virtual host like this: with just the default vhost, S would be available at http://<IP address or host name>/omeka-s

The url I’m working with is:

I am going to put the full path in right now and see if that does it. Thanks! If that doesn’t resolve it, I’ll report back.

Actually. On a re-read of your message I don’t think that’s actually what you were suggesting. Rather it looks like you’re saying I should be able to leave the document root and directory as /var/www/html without any problems.

I tried that and now if I type in it DOES redirect to /install AND now I’m getting a “not a writeable directory” message! Yay! Fixed that with a chmod and now I’m good to go.

Thank you so much!

This topic was automatically closed 250 days after the last reply. New replies are no longer allowed.