Open_basedir restriction on Omeka 2.5 install

I’m working on an Omeka install on a server that I believe has open_basedir restrictions. A fix was posted here for Omeka 1.5:

The problems you’re having look like they’re not related to the Omeka version; they’re the result of restrictive security settings on your server.

In particular, you have an open_basedir setting that prevents PHP from even looking at any files outside the temporary directory and your “httpdocs” directory.

The Zend Framework code that Omeka runs on tries to read through your whole PHP include path when loading files.

Normally, I’d suggest tweaking or getting rid of your open_basedir setting, but I believe this was the same problem you were having several months ago.

Something else that should work: Add the following line to the top of the paths.php file in your Omeka root (it should go after the <?php line):

That should remove all the other directories from your include path and (hopefully) get rid of those errors.

Also, I recommend that you use Omeka 1.5, the most recent version.

I’m wondering if there is a similar fix for Omeka 2.5…?

There doesn’t seem to be a paths.php in the new framework…?

The analogous file in Omeka 2 is “bootstrap.php”. You could try that same line there.

Great - thank you - that does seem to remove a large list of error messages.

On testing of the default imageMagick /usr/bin/ I’m getting a similar message

Warning: realpath(): open_basedir restriction in effect. File(/usr/bin) is not within the allowed path(s): (/var/alternc/html/d/dfaucher/:/usr/share/php/:/var/alternc/tmp/:/tmp/) in /var/alternc/html/d/dfaucher/www/ on line 148

Is there a similar fix that needs to be made here?

Just to further talk through my installation process, I’m working with a hosting service where I don’t have access to PHP configuration and can’t have them modify open_basedir settings on my behalf.