Omeka with OHMS error

I am receiving the following error message when attempting to upload more content. I believe this started to occur with a recent update. Any advice?

[28-Oct-2021 16:01:14 UTC] PHP Notice: Undefined offset: 1 in /home/mcnation/public_html/omeka/application/libraries/Omeka/Job/Process/Dispatcher.php on line 119
[28-Oct-2021 16:01:14 UTC] PHP Notice: Undefined offset: 2 in /home/mcnation/public_html/omeka/application/libraries/Omeka/Job/Process/Dispatcher.php on line 120

What kind of upgrade are you talking about?

These notices (they’re not exactly errors, necessarily) are related to a check we do to see if the PHP CLI is installed and the correct version. There would seem to be some issue with the php command on your server, used for background jobs.

Hello,

On 10/23/2021 it seems that there was an upgrade and my instance of Omeka is now 3.0.1. I am using the OHMS installer and viewer and it does not seem to be instantly compatible with the newest version of Omeka. The last time there was something like this it was the upgrade. Would taking the instance of Omeka back to its previous version correct this problem and if so, what is the easiest way to do that? Thank you, Edwina

I’m not sure the Omeka version is responsible here… possibly other changes your host made at or around the same time? This “PHP CLI” code that you’re seeing a warning from is basically unchanged going back a very long time in Omeka’s history.

Thank you for the update. What has changed is that I get this error message when I try to import new content with OHMS. Is this on the OHMS end then? I ask as the last time I saw it everything worked fine. Now it does not. Its very peculiar. Thank you, Edwina

What webhost are you using?

It’s possible the “change” is something as simple as, you used to have the path to PHP-CLI configured to something non-default (in your application/config/config.ini file) and your host in the upgrade process tossed out this configuration, causing the problem. But that’s just a guess.

Reclaim Hosting. I do believe that I had to change something in order to install the OHMS application. I will look into that lead. Thank you. Edwina

Hello,

That correction worked. Thank you very much, Edwina

Hello! We’re having a similar issue with uploading Ohms xml files. Can you tell me where you received that log snippet from? We’re not getting anything in our Apache logs.
Thanks!
Melissa