Omeka-s vocabulary import problem

I am trying to use the FISH Archaeology Artifact vocabulary put out by English Heritage which is at:

https://heritagedata.org/live/schemes/mda_obj.html

I am wracking my brain as to why this wont work in Omeka-S…I get all kinds of errors, and I have tried just about everything.

For namespace URI I have been using: http://purl.org/heritagedata/schemes/mda_obj

And for the prefix i use: obj

for the vocabulary file i have tried the .rdf, .ttl, and linking the weblink url for each of them.

Nothing works. Can anyone lend a hand on this? Im probably missing something simple.

You are attempting to import an invalid vocabulary. Omeka expects a vocabulary of RDF properties and classes that are used to define an ontology. The FISH Archaeology Artifact Thesaurus (and everything under https://heritagedata.org) is a controlled vocabulary of terms used to describe resources.

Instead of importing the Archaeology Artifact thesaurus, but you may be able to cut-and-paste the terms into the Custom Vocab module.

OK thanks.

So if i create the “Custom Vocab” by cutting and pasting, what am I actually cutting and pasting? Terms, Items, URI?

I know part of my problem is wrapping my head around the Omeka-S language for “vocabulary” and “ontology” because it doesnt seem like the usage is consistent.

Back to my example.

If I wanted to use the controlled vocabulary of heritagedata within “custom vocabulary,” the user would enter an image of an artifact, for instance, and when they go to description, it would have the categories from FISH? I think thats what I want to do, but I think I may be using a sledgehammer to force Omeka into doing what I want it to do!

Please read the Custom Vocab manual Custom Vocab - Omeka S User Manual