Omeka-s "not supported" on GoDaddy cpanel

My omeka-s site (virtualtechnologymuseum.com) stopped working on Nov 1, 2021 on a WildWestDomains (aka GoDaddy reseller) site as an Add On Domain website. Error is “Not Supported” The hosting support folks don’t know why. The site had been working for months up to 10-31-2021. Tried reloading with 3.11 version. Not luck. Just tried a fresh 3.11 install on new on a new different AddOn site. Still get a"Not Supported" error Is omeka-s now an unsupported app on GoDaddy?

I don’t think that message necessarily has anything to do with Omeka S specifically.

It instead sounds like it’s some sort of cpanel PHP configuration issue? That’s not a total match I think with what you’re describing but I would guess it’s something along those lines.

The GoDaddy people have no clue after three attempts to troubleshoot. They say “hire a consultant” I tried to go on the PhPAdmin of the cPanel and look for a mod_usrdir module but could not find it, but I do not know much about this level of work.
Would like to try hosting somewhere else that is known to work to make sure my site functions. Omeka.net host does not allow ftp server access so that is out. Any suggestions on hosts that work? Or someone to help me out on existing cPanel.

We offer isolated hosting for Omeka S instances: Omeka - Omeka Training and Services

You can also try Reclaim Hosting for shared hosting.