Omeka S 2.0.2 can't get Universal Viewer 3.6.1 to work

I have no trouble with the previous versions of both UV and Omeka s working together. I noticed that when Omeka S came out with 2.0.2 I had to wait a bit for UV and IIIF modules to catch up and was delighted when they had. I have both updated and installed, and cannot get them to work. I’m only getting a plain default viewer. Is there some other step I need to take? I notice in Settings, I don’t get as many checkboxes with UV as I used to (there is no option to Append Automatically to item). Also tried Mirador, and I get an empty black box - so somewhere images aren’t being told to use UV or Mirador. How to track this down? If it were a permissions thing I think I’d get an error? i do have error logging on.

I notice show source on any page is weird (note the code in orange instead of /)


Cannot even get to UV with play

When I inspect element with the web developer tools I can see there is a big block of space that is a universal viewer div

I feel like I just need to flip a switch but I don’t know where the switch is

That “red” text in the source is normal, it’s just the “escaped” form of the slash (and several other characters, in some different places in your screenshot).

The “page not found” error is the core of the problem you’re having, I think.

In the new version for Omeka 2, the options to select to add the viewer automatically or manually (in the theme) in each site have been removed (for my other modules too, like Mirador or other viewers), because they don’t do enough things (they just do “display something”).

Now, when you are not editing the theme yourself, you can use the new module Blocks Disposition, that allows to select which widget is available on which page, and in a selected order. So one setting replaces some dozens of settings.

And for the display of the viewer, I don’t know, I need full log.

SOLVED: - or at least getting there - I decided to uninstall every single module except Universal Viewer, IIIF server, and Mirador. Mirador is still empty, but Universal Viewer now appears correctly- so I’ll just not use Mirador - and I will now add in each module one at a time to report back here which one was seemingly blocking UV

Edit: Metadata Browse is the offending module. But we need it - any chance you can try it on a test site to see if you can reproduce my issue? Thank you and thank you for all you do! EDIT! I see there is a newer version…standby! Version 1.2 installed - no dice - still blocks UV

You’re saying that Metadata Browse conflicts with the Universal Viewer?

That doesn’t make much sense to me… All Metadata Browse does is put some links around metadata values. It shouldn’t to be able to cause what you posted a screenshot of, the “play” URL not working.

You’re sure it’s Metadata Browse specifically? I’d certainly be interested to hear if anyone can reproduce that.

With Metadata Browse on, UV doesn’t show up - it’s a big blank white space, the source code seems to think it is there, but it isn’t. With Metadata Browse off, UV is there. The same occurs if we use Mirador instead of UV. However, the default viewer works fine with Metadata Browse. I know it does not make sense, but I too would love to see someone else be able to replicate this.

Note, this occurs in omeka s 2.0.2, whereas all works fine in omeka s version 1.3

The issue is fixed with the development version of Metadata Browse, thanks to @jflatnes.

Updated Metadata Browse and we (angarone and I) are still having trouble with this. Mirador is working (although it needs to be configured differently, which is not working) but the subject field (the “active” one in Metadata Browse) is not a link.
Mirador is prefect for this collection so I’m hoping you can help. Additionally, I am using the viewer json config (item) in site settings and it doesn’t seem to make any changes. Neither do the Mirador plugins. Maybe I could send you links off-forum? Thanks for your help

It works on my servers… Note that when you download a module from github, you should use the “release”, not the master. The master doesn’t contains the dependencies (or run “composer install”).
So I need a link to check.

We do now have the option for a direct link with the metadata browse, but that is only showing on the page to edit item sets and not on the item set page (the public page) ItemSetsEditMetadataPage versus:

I hope these pictures come through.

Got it - the site settings had a special spot for Metadata Browse that was not there before. Once that was set, rather than just in modules, it works